Menu
Reply
Highlighted
  • 1
  • 0
  • 0
Brianocerous
Joining in
4,026 Views
Message 1 of 7
Flag for a moderator

Slow internet speed

I am paying for 240Mb broadband but at the moment the speed is no where near that.4E94304C-E601-4FF9-9E76-1E7E5A9368C1.png

 The ping is 25. Can someone please help explain why this is and how it can be sorted?

 

 

0 Kudos
Reply
  • 10
  • 0
  • 1
DonnieC
Tuning in
3,991 Views
Message 2 of 7
Flag for a moderator

Re: Slow internet speed

Im on the 200mb hi speed version and this is what im getting!!

nearly a year with Virgin now and sky are chasing us for custom so, looks like Sky are going to get my money again as this is pathetic

Screen Shot 2018-03-13 at 19.11.01.png

0 Kudos
Reply
  • 3.94K
  • 466
  • 1.26K
Very Insightful Person
Very Insightful Person
3,977 Views
Message 3 of 7
Flag for a moderator
Helpful Answer

Re: Slow internet speed

@Brianocerous

AFAIK Virgin Media UK don't provide a 240Mbps service but VM Ireland do, are you by any chance in Ireland?

If so, then the staff here will not be able to help as this is a UK forum and they can only help VM UK customers.  There is a VM Ireland forum here:

http://www.boards.ie/ttforum/1546

Also testing on a wireless device (as shown in your screen shot) is not the best way to test a connection, some wireless devices are limited to less than 40Mbps by their WiFi hardware.  Always best to test with a wired PC or Mac with a gigabit Ethernet card.

______________________
Scott

Disclaimer - I don't work for Virgin Media. I'm just another VM user trying to help out so my answers may be wrong Smiley Happy If my answer solves your problem please mark it as helpful as it may help others
My setup: Vivid 200 Optical fibre with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

 

Mark as Helpful Answer if I've helped

0 Kudos
Reply
  • 10.32K
  • 281
  • 591
Forum Team (Retired) Emma_E
Forum Team (Retired)
3,928 Views
Message 4 of 7
Flag for a moderator

Re: Slow internet speed

Hi Brianocerous

 

I would love to take a look at this for you but I am having trouble locating your connection details.

 

Your last log in was from an IP address which doesn't relate to a Virgin Media account, and your sign-up email address is also non-Virgin Media. Consequently I am unable to identify your account. Please pop me a PM (Purple Envelope, top right hand corner) with the following information so we can investigate further.

 

Name on account:

Virgin email address:

Postcode and house number:

Contact number:

 

We'll be happy to progress things for you once we have received your reply.

 

Kind Regards,

 

Emma_E


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 1
  • 0
  • 0
Charlie9
Joining in
1,206 Views
Message 5 of 7
Flag for a moderator

Re: Slow internet speed

a.PNGi'm also getting this issue. our internet speed is EXTREMELY slow. it's gotten to the point where i just end up using my hotspot for internet. i expect it to be a little slower than advertised due to multiple people using internet in the house at once, but this is **bleep**. i'm not sure how much my mum is paying for the internet alone, though ik it's £80 with the boxset included. also even the slowest average speed is more than this at 54mbs claimed to get on the cheapest option. sometimes the internet is pretty good, but other times it's the worst internet i've ever seen

0 Kudos
Reply
  • 1
  • 0
  • 0
Net-Works
Settling in
1,186 Views
Message 6 of 7
Flag for a moderator

Re: Slow internet speed

If you’re looking for a new, super quick way to test your broadband speed, simply say ‘Ask Checknet’ to your Amazon Alexa device. Bit.ly/askchecknet

0 Kudos
Reply
  • 14.59K
  • 432
  • 46
Moderator (Retired) Ralph_R
Moderator (Retired)
1,088 Views
Message 7 of 7
Flag for a moderator

Re: Slow internet speed

Hi Charlie9,

I've run a few checks on your service from this end and both your hub and local circuit report back in good shape, so good speeds should be very achievable. 

I can see that there are currently over twenty devices connected and peak time usage is at times very high, both of which may be a factor in the slow speed result.

To check for any underlying issues it would be helpful if you could ensure that all devices are disconnected and then run a wired check to speedtest.net on a Gigabit capable device.

Keep us posted.

Ralph_R
Forum Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply