Menu
Reply
  • 4
  • 0
  • 0
red56
Joining in
319 Views
Message 1 of 8
Flag for a moderator

Poor upload speeds, download fine

Hi

I am on the 200Mbps service.  For the last month or so my upload speed has been much lower than it should be.  Speed tests done on Speedtest.net provide results ranging from 2 to 5Mpbs upload.  I should be getting around 11.

Download speeds are fine.

Can anyone offer any advice please?

I have the Hub 3.0, set to modem mode connected to another router. Tests were done using a wired ethernet connection.

Thanks

0 Kudos
Reply
  • 10.34K
  • 647
  • 1.36K
jb66
Alessandro Volta
310 Views
Message 2 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

Try a test via the virgin hub to rule out your own equipment

0 Kudos
Reply
  • 4
  • 0
  • 0
red56
Joining in
304 Views
Message 3 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

Hi jb66 - do you mean revert hub back to router mode and try it that way?

 

0 Kudos
Reply
  • 8.56K
  • 877
  • 1.33K
jbrennand
Alessandro Volta
288 Views
Message 4 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

leave it in modem mode and unplug your router and then plug your device into the same port on the hub

--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 4
  • 0
  • 0
red56
Joining in
274 Views
Message 5 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

Hi thanks for the suggestion. I tried it (connect my laptop to ethernet port on hub whilst in modem mode) and it could not connect to the internet.  I guess there is nothing in the modem to assign IP addresses etc... so not sure how that would work..?

0 Kudos
Reply
  • 11.77K
  • 1.08K
  • 2.55K
griffin
Alessandro Volta
269 Views
Message 6 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

Try rebooting the Hub with laptop attached so the laptop's MAC address can be picked up.

0 Kudos
Reply
  • 4
  • 0
  • 0
red56
Joining in
266 Views
Message 7 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

Ah ok.. got it connected now directly via the modem. Still the same performance though unfortunately... 200Mbps download (yay!) 2.5Mbps upload (boo):

 

speedtest.JPG

0 Kudos
Reply
  • 979
  • 46
  • 87
Forum Team (Retired) Tom_S
Forum Team (Retired)
190 Views
Message 8 of 8
Flag for a moderator

Re: Poor upload speeds, download fine

Hi red56, welcome to our community forums,

 

I can see that it has unfortunately been a few days since your latest post regarding this. I am going to send you a PM to confirm some additional details with you so I can take a closer look at this for you.

 

Thanks

Tom_S

0 Kudos
Reply