Menu
Reply
  • 11
  • 0
  • 0
Errol1
Joining in
563 Views
Message 1 of 12
Flag for a moderator

Etherent speed slow

I have Superhub 3, for as long as I can remember, and I have moved the router twice in my house and have two connections on the cable. It the goes into my network Panel and then to various parts of my house each room having at least 2 x RJ45 sockets.

Since just before xmas I noticed my IMAC was very slow on internet, so i loaded the ookla speed test and am only getting 70mbps whereby before i was getting 340-360?? I have since replaced the router at its original entry point and taken my Imac to same point eliminating the rest of the house and I am still on getting 75-80. 

I have spent over two hours on the phone with the virgin Tech guys to no avail. I get around 240mbps on my Iphone 8 using the wireless. Am at my wits end, the tech guys are saying everything is correct!  all i can think of is that the Superhub 3 is faulty...anyone else had this issue.

PS when i am doing the speedtest it races up to about 120 but then levels out to between 50-70.

HELP!!!

0 Kudos
Reply
  • 6.74K
  • 704
  • 1.03K
jbrennand
Legend
557 Views
Message 2 of 12
Flag for a moderator

Re: Etherent speed slow

Sorry, just me being dense but, are you getting these speeds on the iMac on wifi or cable or both? 

Might be worth getting a new long length of Cat6a cable and wiring it up to the Hub with that to see if your cable is "faulty".


--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 11
  • 0
  • 0
Errol1
Joining in
552 Views
Message 3 of 12
Flag for a moderator

Re: Etherent speed slow

Hi, no you're not being dense, its probably me not explaining myself correctly as I am seething.

1, I have physically un plugged my Imac and taken it to the router and plugged it in, and have eliminated the whole house.

2, Nothing else on router.

3, tried all ports on back of router

still only getting 50-70 whereby when it was connected to my network panel I was getting upwards of 340 everytime.

Errol

 

0 Kudos
Reply
  • 6.74K
  • 704
  • 1.03K
jbrennand
Legend
542 Views
Message 4 of 12
Flag for a moderator

Re: Etherent speed slow


@Errol1 wrote:

Hi, no you're not being dense, its probably me not explaining myself correctly as I am seething.


Do you have another device you can wire into the Hub and test that?   Speaking as an Apple only chap, i think it would be odd if the iMac was throttling the speed somehow.  However, there have been several posts on these fora over the last year or so that software on their windoze machines are doing just that (unbeknown to them)  - e.g. Dell's Smartbyte and some antivirus packages.  You don't have something like that switched on do you ?  You can shut it all off of course by booting up into safe mode (thats what the PC users did to prove that this was the cause) but I cant remember on the Mac whether you can still connect to a network when in safe mode - worth a try?


--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 11
  • 0
  • 0
Errol1
Joining in
540 Views
Message 5 of 12
Flag for a moderator

Re: Etherent speed slow

Hey There,

Been racking my brains, and I have just tried using Safari and my main browser after turning Chrome off and lo and Behold just hit 380mbps with my first trySmiley LOL so my Google Chrome must be infected. I loaded Total AV mac cleaner yesterday and cleared a load of rubbish. 

Might have sorted the problem out...now i either have to find out whats wrong with my chrome, maybe delete it and re load or get used to using Safari??

What say you??

0 Kudos
Reply
  • 6.74K
  • 704
  • 1.03K
jbrennand
Legend
532 Views
Message 6 of 12
Flag for a moderator

Re: Etherent speed slow

I say Chrome is the work of the devil - trash it (although my lass loves it) !  I use Firefox as my main browser as I like its "Addons" like Adblock+ and Facebook Purify) - and only use Safari now and then as the backup.  I used to have antivirus running on the Mac lappys but took it off them a few years ago as I found them intrusive - and havent ever had a problem since (touches wood).


--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 6.74K
  • 704
  • 1.03K
jbrennand
Legend
490 Views
Message 7 of 12
Flag for a moderator

Re: Etherent speed slow

FMI - Did you ever reinstall Chrome and try again ?


--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 11
  • 0
  • 0
Errol1
Joining in
479 Views
Message 8 of 12
Flag for a moderator

Re: Etherent speed slow

Hey Mate,

No I didn't, I took your advice and loaded Firefox and getting speeds of 385mbps every time with 21 upload.

Like Firefox, very similar to Chrome..does Firefox have an ad blocker??

 

0 Kudos
Reply
  • 6.74K
  • 704
  • 1.03K
jbrennand
Legend
478 Views
Message 9 of 12
Flag for a moderator

Re: Etherent speed slow


@Errol1 wrote:

Hey Mate,

No I didn't, I took your advice and loaded Firefox and getting speeds of 385mbps every time with 21 upload.

Like Firefox, very similar to Chrome..does Firefox have an ad blocker??

 


Yep - on the Firefox toolbar go to  Tools>Add-ons  and search for Adblock Plus - it works brilliantly for me.  If you get a chance try reinstalling a fresh Chrome and run the speedtests and post up results here - can uninstall it immediately thereafter if its slow


--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 11
  • 0
  • 0
Errol1
Joining in
465 Views
Message 10 of 12
Flag for a moderator

Re: Etherent speed slow

Ok will do tomorrow and thanks👍🏻

0 Kudos
Reply