Showing results for 
Search instead for 
Did you mean: 

Red light on hub 3

Joining in

Hi, I have a solid red light on the front of my hub 3. I understand from other community posts that this means overheat? Has been on a week or so, have tried unplugging it for a while but is still on. Seems to be working ok otherwise. Do I need a replacement hub?


Very Insightful Person
Very Insightful Person

Yes.  A false red warning light is a possible risk. If it persists after a power cycle then the Hub should be replaced. 
Wait here a day or two and a VM Mod will pick this up. 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Ok thank you 

Good Morning @Steveed 🌞 Welcome to our forum and thanks for your post.

I'm sorry to see you are having issues with your hub 3 having a red light. Thank you for trying to reboot the hub as this is what we would suggest to try doing. 

As you have tried this and are still seeing an issue with the hub having a red light I will pop you over a PM to confirm your details. This can then be checked further.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

Forum Team
Forum Team

Thanks for chatting with me via PM @Steveed, you're very welcome for the help 😊

Please let me know how this visit goes, just to bear in mind, someone over the age of 18 will need to be in the property when the engineer visit takes place.

If you do need to cancel or change the appointment, this can be done via your online account here. This will need to be done at least 24 hours before the visit. If it is within the 24 hours just give me a shout and I can help.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

Thank you very much @Nathan_B for your help. Engineer visit was perfect, new hub 3 installed and all Working well. The only issue I have is I cannot get the new hub 3 to show up in the  VM Connect app. I have tried deleting and reinstalling the app but no luck. Any ideas? 

Thanks for the update Steveed,

I'm glad the matter has been sorted for you.

Just to clarify has the App worked previously?

Also has another device been tried?

Let us know,


Good morning,

Tried it agai last night and is now working ok.

Thank you 

No worries at all thank you for letting me know.

Please do feel free to reach out if you need anything in the near future and I hope you have a lovely weekend. Thanks 

Matt - Forum Team

New around here?