Menu
Reply
  • 3
  • 0
  • 0
Adonis72
Tuning in
783 Views
Message 1 of 6
Flag for a moderator

Problem using modem mode with TP Link VR900

I have been trying and failing to set up my Superhub 3 in modem mode and connecting it to a new TP Link VR900 router I bought.

It seems that the router is working fin but is not connecting to the internet, so there must be an issue either in the Superhub or the connection from the Superhub to the router.

I read the advice in this post here:

https://community.virginmedia.com/t5/Forum-Archive/How-do-I-connect-a-TP-Link-VR900-to-the-Superhub-...

I was good advice because I definitely had my router in the wrong mode. It's now in wireless router mode but it still doesn't seem to connect to the internet.

The input connection on the router is an RJ11 so I had to get an RJ45 to RJ11 cable to connect from the Superhub to the router so I only have one of these cables (its a cat5e) and am unable to change the cable to test if it's that, but it's unlikely to be a fault in a new calbe right?

Is there anything else anyone can suggest I might be doing wrong?

 

0 Kudos
Reply
  • 13.25K
  • 1.01K
  • 3.08K
Very Insightful Person
Very Insightful Person
778 Views
Message 2 of 6
Flag for a moderator

Re: Problem using modem mode with TP Link VR900

correct me if i have it wrong but thats an ASDL modem router - if so its not what you want - you need a cable router

so if you bought it new send it back - if it came at a good price you can use it 

the instructions in the link you posted seem ok - if they infact work the mistake you have made is the cable connection forget the RJ11 and go lan to lan

what will work afaik is hub3 in router mode and the VR900 in access point mode - assuming it has one

a third option is turn off DHCP on the VR900 set its ip to something other that 192.168.0.1 connect it lan port to lan port on the Hub3 and you should have wifi and the remaining 3 ports working on the VR900

 

____________________

Tony
  • 3
  • 0
  • 0
Adonis72
Tuning in
767 Views
Message 3 of 6
Flag for a moderator

Re: Problem using modem mode with TP Link VR900

Thanks, I will give that a try this weekend. It is new though so I might send it back and get a cable router instead if it doesn't work.

Cheers!

0 Kudos
Reply
  • 13.25K
  • 1.01K
  • 3.08K
Very Insightful Person
Very Insightful Person
760 Views
Message 4 of 6
Flag for a moderator

Re: Problem using modem mode with TP Link VR900

if you can return it then imo thats the best option - you are really making work for works sake 

____________________

Tony
  • 3
  • 0
  • 0
Adonis72
Tuning in
723 Views
Message 5 of 6
Flag for a moderator

Re: Problem using modem mode with TP Link VR900

Swapped it for an ASUS RT-AC68U and all is good.

Thanks for the advice!

0 Kudos
Reply
  • 37
  • 0
  • 0
mkaminski100
Joining in
453 Views
Message 6 of 6
Flag for a moderator

Re: Problem using modem mode with TP Link VR900

VR900 router works like a charm with Virginmedia. Fact that router is fitted with a modern doesn't mean it must work as one.

This is how it worked for me.

RJ45 cable goes in the socket closest to the coax cable on the VM superhub and socket 4 on the VR900. Grey RJ11 socket will not work with  VM service.

Turn the router on. Log in (type tpilinkmodem.net ) and click on options. Do not try to go through the initial setup as this is intended for cable.

When you click on options chose router option.

Then go through the initial setup which is very easy. For most technical questions, just leave the highlighted option.

This router operates on 2 independent networks -2.4 and 5 GHz. Just choose 5Ghz where possible. 2.4 is for older and many cheap Chinese devices. Both frequencies work together so all devices will be visible to users connected to the hub.

The only downside is that you lose one RJ45 socket, but you can leave VM and have router/modern ready for cable.

0 Kudos
Reply