Menu
Reply
Sofie_Paakj
  • 2
  • 0
  • 0
Joining in
236 Views
Message 1 of 5
Flag for a moderator

Missing registration but hub arrived

My hub arrived after ordering it on the phone. 

He must have gotten my email address wrong because I never received a registration email with login info, account number, and so on. This means I'm not receiving any bills either, but they're charging me. 

I urgently need to be able to log into my account - or register with one - but since my correct email address is not in their system and I don't have an account number, I'm stuck. I can't get through to them by phone because they ask for characters of my password that I never created, because I didn't get a registration email.

When I use the "I've forgotten my password" tab it says my email address isn't in their system. 

Thank you for any help in advance. 

0 Kudos
Reply
Chris_W1
  • 4.06K
  • 185
  • 255
Forum Team
Forum Team
203 Views
Message 2 of 5
Flag for a moderator

Re: Missing registration but hub arrived

HI Sofie_Paakj, thanks for the message and we are sorry to hear that you are having issues with the online account. Can you confirm if you would have used any other email? The account number and area reference will be on the bill and we would be able to send this out to you. Can you confirm if you are still having issues with this or have since managed to get this resolved? Please let us know and we will aim to assist further ^Chris 

0 Kudos
Reply
Sofie_Paakj
  • 2
  • 0
  • 0
Joining in
192 Views
Message 3 of 5
Flag for a moderator

Re: Missing registration but hub arrived

thank you for your reply. I can confirm that I would not have used any other email. How can I provide the correct email, so I can receive the bill and registration email? I have since my last post been charged for this month as well without receiving a bill. 

0 Kudos
Reply
Chris_W1
  • 4.06K
  • 185
  • 255
Forum Team
Forum Team
188 Views
Message 4 of 5
Flag for a moderator

Re: Missing registration but hub arrived

HI Sofie_Paakj, I will send you a private message to get this looked at further - Chris 

0 Kudos
Reply
Chris_W1
  • 4.06K
  • 185
  • 255
Forum Team
Forum Team
167 Views
Message 5 of 5
Flag for a moderator

Re: Missing registration but hub arrived

HI Sofie_Paakj, we are glad that everything is working correctly, can you let us know if anything changes? Have a good day. ^CW

0 Kudos
Reply