cancel
Showing results for 
Search instead for 
Did you mean: 

Hub 5

Fozzybear2
On our wavelength

My hub 5 has just turned up and after opening the box that the power supply was missing .

1 ACCEPTED SOLUTION

Accepted Solutions

  • I have also been without any internet service as the gig1 plan does not work with the hub 3 and virgin are unable to restore it back to my previous plan (or so I am told) for the last three days. 

See where this Helpful Answer was posted

13 REPLIES 13

SNK
Dialled in

A few people on this site have reported this. Have you checked all the packing under the router box as some find it there as I did. If not it would be quicker to phone 150 on a VirginMedia phone or 0345 454 1111 from a non Virgin line.

Fozzybear2
On our wavelength

just finished with them to order a power supply , which should have been checked to see if everything was in place before sending out . I have had to put annual leave in to receive the parcel this morning so I am not impressed that I cannot access the service . 

Glad you're sorted seems to be a regular problem now days which should never happen in the first place.

Fozzybear2
On our wavelength

It’s called Quality control, which seems to seriously lacking after looking at other posts . Then it may save virgin money if they got it right more often . 

After waiting a week and three calls (and three orders )to virgin the power supply for the hub 5still hasn’t arrived . Virgin have now changed my plan which doesn’t work with the hub 3. If it doesn’t turn up by this evening I will be cancelling my contract and going somewhere else.

Good Morning @Fozzybear2, thanks for your post and welcome back to our Community Forums!

I'm terribly sorry to hear of the issue with the equipment that was sent out to you.

Can you confirm if this has now arrived to you?

You also mention a change in your plan, can you possibly expand on this for me?

Kindest regards,

David_Bn

I changed my plan to the gig1 plan and the hub5 which arrived on the 1st of October .On opening the box I found no power supply , I then contacted virgin customer service who said they would send a adapter out and I would receive this in 48hours . It didn’t arrive. Now on four separate occasions I have had this conversation, virgin even stating it has been delivered twice . On my property I have security cameras all round so I know it hasn’t and I wouldn’t be calling again if it had.I am now waiting for the adapter to arrive today which I doubt it will . Either I am being lied too or they are delivering it to a different address. Wish I now had never swapped .

  • I have also been without any internet service as the gig1 plan does not work with the hub 3 and virgin are unable to restore it back to my previous plan (or so I am told) for the last three days. 

Zoie_P
Forum Team (Retired)
Forum Team (Retired)

Hi Fozzybear2, 

Thank you for your post 🙂
I am so sorry to hear this, I have checked our systems and can see you have been in touch with our team, have they managed to assist with this?

If not let us know and we will do our best to help.

Zoie