Showing results for 
Search instead for 
Did you mean: 

Connect app

On our wavelength

Why can’t the Connect app see my hub 3


Thanks for those details wingtsz2003.

I did check the whole account sorry nothing at all showed up.

We do currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. A reboot usually resolves this. We are investigating this as a high priority. Apologies for any inconvenience.


I can log in but when prompted to connect to my hub, it tries for a while then I get the same message shown earlier in this string, ie can’t find the hub. I’ve rebooted the hub and reinstalled the connect app

I have

rebooted my hub 3,

deleted and reinstalled the app. 

tried to download it on my wife’s iPhone my iPhone and my iPad but still get the same message. 

I called customer service who didn’t really understand my issue

Hey drschwing,

Welcome to the community and thanks for taking the time to post here on the forums.
I’m sorry to hear of the issues that you’re having trying to connect your hub and the Connect App, we do have a known issue and this is being looked into at the moment.

What are you trying to do with the Connect App? Some activities can be done via other means.

Kind Regards,


Joining in

I am having the same issue as everyone else. I have only just had the broadband installed today and so far the service has been awful. The app doesn’t find the hub3 I have even though everything is setup correctly as the engineer did this earlier. 
I have tried installing the app on my iPhone and iPad and neither finds it. Can someone please fix this without copying and pasting the same message from previous messages. Thank you. 

Forum Team (Retired)
Forum Team (Retired)

Hi @darbell87,

Welcome to our Community Forums! Thank you for your first post and I'm very sorry to hear that you're having some issues with your Connect App.

I can see that you've recently been in touch with our team. Can you tell us if this has helped with your connection issue, or are you still experiencing problems?

Let us know so we can help.

Thank you.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

You’re team have not been able to resolve the issue. 

Hi darbell87,

Thanks for coming back to us. We're sorry that you our team we're unable to resolve the issue, however remotely checking the systems from our end, we can see you have contacted the team since your last post.

Were our team able to assist with your query?

Kind regards Jodi. 

No they weren’t. The app still doesn’t find my hub. 

Hello darbell87.

Sorry you are having the same issue connecting via our App.

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:

For your Apple device, if you're on iOS 15 then you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. If you're on iOS 16 then just delete the app from your device, restart the handset and then redownload the app. 
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 
If this also fails then we currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. We are already investigating this as a high priority.

Pop back and keep us posted.


I'm having the same issue also, Connect App is unable to detect my modem.  

I've tried installing it on several IOS and Android devices connected to my WiFi, and I've also tried factory resetting my modem. I've uninstalled and reinstalled it, cleared the cache and even installed it on a brand new Samsung tablet that was just taken out of the box and connected to the WiFi. 

Please don't respond with the same troubleshooting steps...