Showing results for 
Search instead for 
Did you mean: 

Connect app cannot find my hub3

Tuning in

Hi, the Connect App can never find my VM Hub3 but the broadband sevice is working fine. I already did all suggested action like hub and app re-installation, device os and app verion upgrade, tried to use the app in different devices, however, it still doesn't work.



is there any update on this issue?

I’ve had a brand new Hub 3 installed earlier today and M350 broadband activated. The broadband is working fine, but I’ve installed v12.32.7 of the Virgin Media Connect app onto  my iPhone 12 which is running iOS 16.1.2 and the Connect app cannot find my hub 3. I’ve tried all the suggestions on this community board but it simply won’t work.



Hi Phillmo359, thank you for reaching out and a warm welcome to the community. 

We're sorry to hear you're having an issue with the Connect App recognising your hub. 

The first thing to be aware of is you need to be connected to your Home WiFi in order for the app to connect to the Hub. It won't allow the connection if you're on a Guest network, VPN or Mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that: 

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

If this also fails then we currently have a known error with some of the data in our systems, that is causing the app to not recognise the Hub in a minority of instances. We are already investigating this as a high priority. 

Pop back and keep us posted. 


Matt - Forum Team

New around here?

Hi Matt

I haven’t changed any settings on my iPhone, but I retried the Connect App again this morning and instead of saying cannot find hub, the app screen said gathering data. After approximately 30 seconds the app connected to my hub 3 and I was able to run a speed test, which showed everything was working fine. Don’t know what’s changed, but I’m happy the app is now working and I’ve been able to do a wifi scan in each room around my house.



Hi Phillmo359, good to hear your app is now working. Unfortunately, my app problem still exists and no way I can access to my VM hub.





Thanks for coming back to us Ukallen. I would be happy to take a further look into this and raise it with our IT support team if necessary. I will send a private message over in a moment, please look out for this and we can get started.

Kind Regards,


Thanks for confirming your details via private message. Which version of the app, are you using Android or iOS?

Kind Regards,



Hi Steven, it's Android.


Thanks for confirming that UKallen, I will now send over a private message with the details that we need to get this raised with the support team. Please look out for my message.



Thanks for confirming your details via private message, I have raised this with our support team and I will get back in touch with you as soon as I have any further updates.

Kind Regards,


Thanks for your help Steven