Menu
Reply
  • 18
  • 0
  • 0
strawb
On our wavelength
1,116 Views
Message 1 of 13
Flag for a moderator

Cable broken from hub 3.0

My Internet cable has been broken from the router hub, the part which was inside the hub come through and out of the router. Can it be replaced for free or not. Does anyone know? I can't screw it back in myself.     

Any advice would be appreciated

 

 

0 Kudos
Reply
  • 18.64K
  • 1.62K
  • 4.06K
Superuser
Superuser
1,105 Views
Message 2 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

hiya @strawb would be around 3-5+ days for the forum admin to arrange replacement or contact broadband support via 150 / 0345 454 1111
----------------------------------------------------------
If someone's helped you out say thanks by clicking on the thumbs up. If someone's solved your problem, why not mark their message as an Accepted Solution
  • 18
  • 0
  • 0
strawb
On our wavelength
1,059 Views
Message 3 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

I have my first router super hub 2.0 and I I am wondering if I could use that till my problem with the hub 3.0 is sorted? Anyone know if that would be possible?

0 Kudos
Reply
  • 18.64K
  • 1.62K
  • 4.06K
Superuser
Superuser
1,055 Views
Message 4 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

you only need the hub3 if moving onto package 300mbps+ tiers
----------------------------------------------------------
If someone's helped you out say thanks by clicking on the thumbs up. If someone's solved your problem, why not mark their message as an Accepted Solution
0 Kudos
Reply
  • 18
  • 0
  • 0
strawb
On our wavelength
1,051 Views
Message 5 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

I had to sign a contract for the hub 3.0 and was given vivid 200 broadband package. And charged 20 pound activation fee, just because I wanted the Upto date router.
0 Kudos
Reply
  • 1.75K
  • 173
  • 416
vircom
Super solver
1,018 Views
Message 6 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

You would need to phone in to see if they can reactivate your old hub, but if it was not a recent change you may be out of luck. You did not need a hub 3 and I don't believe it would have been any improvement over the hub 2 unless you are in a congested area. Some would say it was a backward step but for most I think it is about the same. I was offered a hub 3 but kept my hub 2 as it worked fine with my Vivid 200 and 2 V6 boxes. Have since switched to modem mode and purchased my own router to improve wifi performance and set up options, but not essential.
  • 18
  • 0
  • 0
strawb
On our wavelength
987 Views
Message 7 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

IMG_20180226_010345_375.jpgThis is what came 0ut

0 Kudos
Reply
  • 18
  • 0
  • 0
strawb
On our wavelength
974 Views
Message 8 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

IMG_20180227_202034_155.jpg

 

 

0 Kudos
Reply
  • 18.64K
  • 1.62K
  • 4.06K
Superuser
Superuser
970 Views
Message 9 of 13
Flag for a moderator

Re: Cable broken from hub 3.0

adding further posts is just putting this further back in the queue for the forum admin to answer, if your waiting on them responding since they answer oldest first.
----------------------------------------------------------
If someone's helped you out say thanks by clicking on the thumbs up. If someone's solved your problem, why not mark their message as an Accepted Solution
  • 10.3K
  • 275
  • 600
Forum Team
Forum Team
986 Views
Message 10 of 13
Flag for a moderator
Helpful Answer

Re: Cable broken from hub 3.0

Hi strawb, 

 

Welcome to the forums, I am sorry to see you have been having trouble with your Hub's cable. 

 

I will pop you a PM to discuss this further. 

 

Keep an eye out for the purple Envelope, top right hand corner. 

 

Speak to you soon. 

 

Emma


New around here? To find out more about the Community check out our Getting Started guide