Menu
Reply
Highlighted
  • 37
  • 0
  • 0
Tuning in
158 Views
Message 1 of 4
Flag for a moderator

add Netgear PL1000?

I was provided virgin media powerline adaptors.. the Netgear PL1000 and they work well. I need another one.. but Virgin Media dont seem to support/provide these any more.. so can I just buy a standard Netgear PL1000 and it will work/connect to the existing ones OK? or have Virgin media configured so only Virgin Media branded ones will talk to each other?

Anyone know? and can advice?

Thanks in advance. Cheers

Tags (1)
0 Kudos
Reply
  • 2.51K
  • 182
  • 344
Superfast
120 Views
Message 2 of 4
Flag for a moderator

Re: add Netgear PL1000?

In a word yes, you should be able to add more devices:

https://kb.netgear.com/22165/Adding-a-powerline-adapter-to-an-existing-powerline-network 

I can't imagine VM would have proprietary standards for powerline adapters.

Give it a whirl, you could always return the new kit or by some second hand ones to replace the VM adapters!

0 Kudos
Reply
Highlighted
  • 37
  • 0
  • 0
Tuning in
68 Views
Message 3 of 4
Flag for a moderator

Re: add Netgear PL1000?

Thanks.. I took the plunge and ordered the standard netgear PL1000

They arrived and turned out to be PL1000V2, but they compatible. I plugged in one new PL1000V2 and hoped the original virgin devices were on factory standard encryption (so the new would connect without issue).. but it was weird, it did connect - but got really slow performance (speed LED red) and only 2mbs download speed... so I gave up - and did a factory reset on the two virgin media devices.. and then after a few mins they all seemed to sort themselves out and I got green light speed on all. 

Interestingly - while they sorting themselves out.. my whole internet went down, so my PC (not connected to any homeplug) showed no internet connection, and would not connect to the router. Also .. when I reset to factory the homeplug connected to my daughters PC.... that randomly rebooted.  So  some strange coincidences there .. or the encryption config process can seriously mess with other items on network..  Anyway - I dont plan to retest to see if coincidence.. or related.. its working now.. so will leave well alone.

Cheers

0 Kudos
Reply
Highlighted
  • 2.51K
  • 182
  • 344
Superfast
54 Views
Message 4 of 4
Flag for a moderator

Re: add Netgear PL1000?

Glad to know it worked out... eventually!

0 Kudos
Reply