Menu
Reply
  • 3
  • 0
  • 0
derlane
Joining in
2,084 Views
Message 1 of 7
Flag for a moderator

Your ISP's DHCP does not function correctly

I have an external ASUS RT-AC5300 router connected to the VM SH3 in modem mode. Been working fine for over a year and then all of a sudden the router cannot connect to the internet and displays "Your ISP's DHCP does not function correctly". Communication issue between the modem and the router regarding DHCP :-(  In my WAN setup I have connection type set to AUTOMATIC and wondering if it's due to the ASUS default DHCP range clashing with the VM SH3 DHCP modem mode range ? No expert and thinking of trying to set connection type to STATIC in my router with settings like:

ip 192.168.100.2

sub 255.255.255.1

gateway 192.168.100.2

More importantly has anyone had the same issue using an external router and VM SH3 ?

0 Kudos
Reply
  • 316
  • 23
  • 34
FlashPan
Fibre optic
2,079 Views
Message 2 of 7
Flag for a moderator

Re: Your ISP's DHCP does not function correctly

When in modem mode the SH3 does not have any DHCP capabilities for your connection.

The default IP of the SH3 is 192.168.100.1, (that should also be the Asus wan gateway address) so you should be able to set any 192.168.100.x ip  on the Asus wan port.

I would check/change the Asus wan ip setting (or how it gets its ip address).  Try setting it manually.  If all else fails then master reset on the Asus to clear out any gremlins.

Cheers

0 Kudos
Reply
  • 3
  • 0
  • 0
derlane
Joining in
2,065 Views
Message 3 of 7
Flag for a moderator

Re: Your ISP's DHCP does not function correctly

Thanks for the reply.

WAN.jpgLAN.jpgIn LAN2.jpg

0 Kudos
Reply
  • 231
  • 6
  • 25
Timwilky
Superfast
2,064 Views
Message 4 of 7
Flag for a moderator

Re: Your ISP's DHCP does not function correctly

So wrong

 

The hub in modem mode will serve a single DHCP address to your router. The hub/modem will have an admin interface on 192.168.100.1. But this is admin only. Not as suggested the default gateway. That will be supplied in the DHCP config.

0 Kudos
Reply
  • 3
  • 0
  • 0
derlane
Joining in
2,063 Views
Message 5 of 7
Flag for a moderator

Re: Your ISP's DHCP does not function correctly

In terms of the screenshots what exactly would I need to change ?

0 Kudos
Reply
  • 12.35K
  • 466
  • 1.1K
legacy1
Alessandro Volta
2,036 Views
Message 6 of 7
Flag for a moderator

Re: Your ISP's DHCP does not function correctly

If your having problems getting a WAN IP try the following.

Asus router to DHCP with the hub in modem mode power off for 2mins then on your Asus router should get the WAN IP.

If that fails connect a PC to the modem mode port and make it get the WAN IP and internet then copy the MAC of the PC to your Asus router WAN and connect that to the modem mode port.

0 Kudos
Reply
Highlighted
  • 17
  • 0
  • 0
itm
Joining in
1,406 Views
Message 7 of 7
Flag for a moderator

Re: Your ISP's DHCP does not function correctly

It turns out that it was a problem with the Virgin Hub. I spent half an hour on the phone with Virgin Support. They eventually suggested doing a hard reset of the hub (pressing and holding the reset button for 40 seconds), and it resolved the problem.

0 Kudos
Reply