Showing results for 
Search instead for 
Did you mean: 

Virgin Media having issues with googles DNS?

On our wavelength

Hello first time here sorry if this isn't the right place to ask questions.

I'll just get right to the point since Virgin Media forced the new firmware update to the hub 4 my internet as been slow loading pages. So I've done all the usual tricks, reboots, hard resets, the whole nine yards. So I decided to do some command prompt ping tests and I've noticed I'm dropping around 5% packets to googles primary DNS server. I've never had a packet loss issue before. Now from my understanding if it was my internet in general, I would drop packets to everything but I don't just googles primary one.

Pages can take 30 seconds to loads, streams will buffer unless I refresh a few times. My internet is super sluggish. Speed tests show my full speed its super weird behaviour. Is it possible that Virgin Media are having communication issues with googles primary DNS? Changing my DNS servers doesn't do anything and it's the same on 3 different PC's same goes for wired or wireless.



it would be good to understand the type of device / web browser / method of connection to the Hub.

Have you tried this link to see if there is lots more latency and jitter at your device that at the Hub :     ( once started click on Run full test )

There are recent & similar reports for the Safari browser, folks also mentioned that delays or page lags vanish with other browsers.

So do the test with which ever web browser is the worst and then try a different web browser too.

My speeds look fine using that site with 5ms jitter and 0% packet loss. I've tested it on 3 different browsers Firefox, Chrome & Edge all have the same problem. Issues persist across 3 different PC's wired and Tablets and Mobiles have the same problem loading web pages slowly and sometimes pictures on websites don't even load at all.

I've done plenty of packet loss test and only lose packets to googles primary DNS, My thinking is Virgin Media currently have some sort of routing issue. Today I have seen a few people on this forum saying the same thing with webpages loading slow or  pictures not loading on webpages.

I'm unclear why you are banging away at the front door of Googles Public DNS and are load balancers to a global network of DNS servers.

Sending 5 pings results answers from 5 different end points - some may well be set to drop non DNS queries.

I'm no expert clearly, but I keep mentioning Googles DNS because I'm only dropping packets while pinging that when I never did before my issue started. When I've never dropped packets at all before my issue started. So I'm obviously drawn towards it, my apologies.

I suffer with chronic OCD so when anything happens that isn't the norm my mind goes into melt down doing test after test. The reason I know I've never had issues with dropped packets before is because if my internet as a hiccup I run tests like a madman there's nothing I can do about it. Again I apologies that I'm banging away at the front door of Googles Public DNS it's just that's the only thing that's changed in comparison to my other tests. But I'm more than happy to listen to other things I can do to try and fix the problem. I've tried everything I know from rebooting, hard rebooting, making sure all cables on tightly connected, tried using different DNS, different browsers, wired/wireless and on different PC's.

Thank you for replying it's much appreciated. 

Very Insightful Person
Very Insightful Person

Are you able to provide:

  • an example of a site that is loading slowly?
  • ping result for site?
  • trace route to site?


If you want to see Google Public DNS working set your iphone or PC's DNS to and or your Android device to

You never know it might help with the webpage speed issues.

Basically any site but for Reddit or Twitter, Facebook for example the site might take 20 seconds to load and the when it does load the pictures will either slowly load or wont load at all. Another example is Twitch all streams buffer or won't load at all. But if you refresh a few times It works without a problem is such strange behaviour. This behaviour happens across different devices.

I've tried this but the issues persists unfortunately.

Very Insightful Person
Very Insightful Person

What result are returned when you ping and trace router the following domains?