Showing results for 
Search instead for 
Did you mean: 

Virgin Media having issues with googles DNS?

On our wavelength

Hello first time here sorry if this isn't the right place to ask questions.

I'll just get right to the point since Virgin Media forced the new firmware update to the hub 4 my internet as been slow loading pages. So I've done all the usual tricks, reboots, hard resets, the whole nine yards. So I decided to do some command prompt ping tests and I've noticed I'm dropping around 5% packets to googles primary DNS server. I've never had a packet loss issue before. Now from my understanding if it was my internet in general, I would drop packets to everything but I don't just googles primary one.

Pages can take 30 seconds to loads, streams will buffer unless I refresh a few times. My internet is super sluggish. Speed tests show my full speed its super weird behaviour. Is it possible that Virgin Media are having communication issues with googles primary DNS? Changing my DNS servers doesn't do anything and it's the same on 3 different PC's same goes for wired or wireless.


Nope the issues persist 1Gib fibre running like I'm on dial up, websites still taking a age to load. Luckily I'm starting to see more people mentioning almost the same problems on here and other places. 

Forum Team (Retired)
Forum Team (Retired)

Thanks for replying and sorry to hear the issue persists and the hub replacement did not help resolve it, Kerrigoonaz.

We'd love to help, could you please run a few speed-tests while on modem mode (as seen here) as well as safe mode to see what's the values returning and if the issue is present there too?

Also, do you have any other devices you can connect via ethernet and run these checks to compare between the two, perhaps?

Let us know more and we're eager to assist further.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

This isn't a issue on a certain device, we have 3 PC's all connected by ethernet cable two using cat7 cables and the 3rd using cat6 cable the issue happens on all 3. The issue is also happening on Wi-Fi devices Phones, Tablets, Xbox's. I've already tried it while using one device in modem mode on 3 different devices to rule that out. This is a issue on your side not mine and it needs fixing. I'm paying for 1Gig fibre and it's loading pages and buffering video like I'm on dial up yet speed test show my full speeds which is odd. I'm not the first person on this forum who is having the exact same issue.

Edit: I've also tried using different DNS servers.

run CMD

Heading into the 17th day now of my internet not working as it should. Webpages still not loading correctly or taking an age to load even though my speed tests show my speeds are fine. Happens on multiple devices wired or wireless. I've tried different DNS servers, I've tried testing the router in modem mode. I've reset and rebooted the router, I've even had a new router installed. I've tried everything on my end.

It's becoming unacceptable now.. 

run this

The title subject for this post isn't correct anymore, it needs changing to something else. I don't think it's a DNS issue anymore. I think it's something deeper regarding their network. It's happening to alot of people in my area but when you ring the 0800 number for faults it says everything is fine.

Hi Kerrigoonaz 


Thank you for your post and welcome back to our community. I am very sorry to hear about the service issues you are experiencing.


I have taken a look at things from our side and there are no known outages reporting currently for your area. 


Do you currently have the Hub in Modem or router mode please?


Please pop back to us when you can.





Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Alessandro Volta

@Vikki_M wrote:

Do you currently have the Hub in Modem or router mode please?


Does it really matter.😤 


I've tried everything on my side this is a VM issue not a me issue. I pay good money for a service that's not working correctly. It was all working 100% perfect until about 20 days ago. Ever since then everything loads like I'm on dial up speeds if it loads at all. Loads of people having the same issue. City fibre are currently installing full fibre lines in my village, so I would get looking into this issue fast otherwise you'll be losing a whole lot of costumers.