Menu
Reply
  • 2
  • 0
  • 0
Joining in
148 Views
Message 1 of 5
Flag for a moderator

TiVo box won’t connect to router via ethernet

Hi. I use my Virgin Media router in modem mode and have a Linksys mesh WiFi network running, with the main Linksys unit connected via Ethernet. I’ve also had my TV box plugged into the mater Linksys unit with no trouble. I have changed my setup and have tried to connect the TiVo box directly to one of the Ethernet ports on the router.

When the cable is unplugged the network icon on the TiVo box is red. When plugged into the Virgin router the same icon flashes white but the box says the cable in unplugged. The Ethernet port on the router is also flashing, showing it recognises the connection.

The same cable works when plugged into the Linksys unit and I’ve tried rebooting both the router and the Tivo box. Does anyone have any ideas?

Tags (1)
0 Kudos
Reply
  • 28.34K
  • 1.7K
  • 3.66K
Alessandro Volta
143 Views
Message 2 of 5
Flag for a moderator
Helpful Answer

Re: TiVo box won’t connect to router via ethernet

In modem mode only one port works.

You need to connect all other wired connections to the Linksys - if it doesn’t have enough ports you need to get an unmanaged desktop switch to connect to the Linksys to provide additional connectivity.


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
  • 2
  • 0
  • 0
Joining in
100 Views
Message 3 of 5
Flag for a moderator

Re: TiVo box won’t connect to router via ethernet

Thanks. Is there no way to manually override this and enable additional ports on the router? I guess the only other way would be to have it not operating in modem mode and just ensure that the two WiFi networks in the house are on different channels?
0 Kudos
Reply
  • 28.34K
  • 1.7K
  • 3.66K
Alessandro Volta
95 Views
Message 4 of 5
Flag for a moderator

Re: TiVo box won’t connect to router via ethernet


@WolframWolfred wrote:
Thanks. Is there no way to manually override this and enable additional ports on the router? I guess the only other way would be to have it not operating in modem mode and just ensure that the two WiFi networks in the house are on different channels?

No. You do as above and buy a switch to connect to the Linksys.

Just a simple gigabit 5 or 8 port switch for around £20 will suffice.


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
  • 15.27K
  • 1.17K
  • 1.92K
Alessandro Volta
91 Views
Message 5 of 5
Flag for a moderator

Re: TiVo box won’t connect to router via ethernet

As Gary says, you need an unmanaged switch. You would end up with something like this, the spare ethernet ports on the Router can also be used.

WD-LAN-Drive

 


*********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
BT Smart Hub 2 with 70Mbs Download,18Mbs Upload, 9.17ms Latency & 0.35ms Jitter.
0 Kudos
Reply