Menu
Reply
  • 4
  • 0
  • 0
Gghxx7
Joining in
299 Views
Message 1 of 8
Flag for a moderator

The worst service yet

Truly disheartened by the recent service I've been receiving from Virgin I have no other choice but to leave.

Advertised as up to 100Mbps (download) I'm receiving 3Mbps and this is having ran through every possible solution to obtain the 'fastest' speed. I've used wired, connected only one device, reset the Hub, set up manual DNS, listened to every word of advice and yet to no avail.

I've wasted 2 afternoons in contact with customer service after being on hold for a total of an hour, having been told by 2 of the employees on 2 separate occasions that the problem will be escalated to the manager, as per my request, and that I'd receive a phone call within 'one hour maximum'. These phone calls were over a week ago and a day between each other. Not only have I not heard from them the service has gotten worse to the point nobody can use it in the flat.

I'm not prepared to sit on the phone and waste my weekend again to try and cancel the service, what are my options?

0 Kudos
Reply
  • 12.6K
  • 482
  • 1.12K
legacy1
Alessandro Volta
268 Views
Message 2 of 8
Flag for a moderator

Re: The worst service yet

Maybe you have packet loss? Setup a BQM and post the live link
https://www.thinkbroadband.com/broadband/monitoring/quality

0 Kudos
Reply
  • 4
  • 0
  • 0
Gghxx7
Joining in
250 Views
Message 3 of 8
Flag for a moderator

Re: The worst service yet

My Broadband Ping - Virgin
0 Kudos
Reply
  • 9.41K
  • 978
  • 1.48K
jbrennand
Alessandro Volta
226 Views
Message 4 of 8
Flag for a moderator

Re: The worst service yet

looks ok so far
You need to run the speedtest like this... , you need to do it this way first.

Make sure your device has a gigabit network card (not a 10/100 one or “limited to that) and has the up to date drivers. Use a new Cat6 ethernet cable (old ones do "break" and Cat6 is best) to connect it directly to the Hub - which you have put into modem mode (to ensure only your device is connected). Check speeds like that first which I think you have, then.... boot up your device into "safe mode with networking" (to disable any software on it that could be limiting speeds). Run the tests at speedtest.net (try on x2 VM servers) on 2 different browsers one of which is a fresh download of one you haven’t previously used (e.g. Firefox, Opera, Safari etc - there are several reports on here of certain browsers causing speed issues).

--------------------
John
--------------------

My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
  • 4
  • 0
  • 0
Gghxx7
Joining in
198 Views
Message 5 of 8
Flag for a moderator

Re: The worst service yet

Appreciate the reply but I know it's not my hardware that is to blame. It's a £1k Dell that has very confidently hit 90-100Mbps previously with Virgin it's only been in the last 2 weeks that this problem consistenly happens. I've used the Cat5 cables, powerline adapters whilst it provided a very slightly better DL it is really no where close to what I originally had. 

If it was a problem with the hardware, all of the other devices wouldn't experience the same network symptoms.

0 Kudos
Reply
  • 9.41K
  • 978
  • 1.48K
jbrennand
Alessandro Volta
172 Views
Message 6 of 8
Flag for a moderator

Re: The worst service yet

Dell recently updated their "Smartbyte" software and irtcan run in the background un-beknown to the user - it limits connection speeds on individual devices. Check and see if yours is running.

https://community.virginmedia.com/t5/Speed/Download-speeds/td-p/3894056


--------------------
John
--------------------

My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 4
  • 0
  • 0
Gghxx7
Joining in
153 Views
Message 7 of 8
Flag for a moderator

Re: The worst service yet

Hi jbrennand, thanks for the reply.

I've tested the speed on multiple devices and the advertised "average of 100Mbps" would be better advertised as average of 10Mbps!

The fault may be within the hardware but I've tested multiple phones, tablets and laptops and considering this problem has arisen all of a sudden I doubt they are to blame. I am also extremely discontent with the customer service as well as alterations to my package which I have not asked for. I've been told I'd be contacted by a manager twice and I've had no contact of the sort.

How do I leave without going through their customer service by phone?. Is there a simpler method to leave?

0 Kudos
Reply
  • 9.41K
  • 978
  • 1.48K
jbrennand
Alessandro Volta
144 Views
Message 8 of 8
Flag for a moderator

Re: The worst service yet

Have you done the speedtest as I suggested ? That will confirm or not whether the Hub is receiving >100Mbps. If it is then its likley your hardware/software that needs attention - if it doesnt then it "proves" the issue lays with VM.
But you dont have that data.
To cancel you have to call in - call “Retentions” on 150 or 0345 454 1111 - options 1-1-4-5 "Thinking of leaving" - they are open 8am until 10pm but calling early (between 08.00-11.00 is usually best) you will usually get a UK call centre who’s staff are more informed and helpful.

--------------------
John
--------------------

My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply