Menu
Reply
Highlighted
  • 9
  • 1
  • 1
marcixxx
Tuning in
2,597 Views
Message 1 of 19
Flag for a moderator

Superhub 3 port forwarding issue

Hallo everyone.

As others members, pointed out more than 1 year ago, the new VM Superhub 3, have a big issue regarding 'port forwarding'.

I have 3 pc at home.

Sometimes i need to connect from 'outside' to my home pc's 'via' rdp.

I've contacted customer center, and an operator haved a 'logMeIn session', in my pc, and he verified that, with the current (newest) firmware, the Superhub 3 have 'still' the issue that don't allow to set correctly the port forwarding.

In particular, the superhub3 don't allow to set a rule, where internal port is different to external port!!!

But the problem is that in a normal Windows rdp session, the local port is 3389, but the external port have a number (ephemeral) between 49152 to 65535.
As explained i.e. in this thread
https://superuser.com/questions/1118735/how-are-source-ports-determined-and-how-can-i-force-it-to-us...

So VM technician was unable to set correctly the rule too.

And he passed me the call, to an ingeneer.

The ingeneer simply told me that '...Virgin Media, don't provide no more Port Forwarding feature' to their customers.
I've asked him if is possible that an ingeneer come to my home with an old 'Superhub 2', and try to set up the current Superhub3 in modem mode, and use the old Superhub 2 as a router.
But engineer told me that this is not possible.

So at this point i have only 2 solutions.
1) Buy my own router, and set up the Superhub 3 in 'modem mode'.
Then use my own router and set it for a 'safe' port forwarding.
2) swap to BT or Sky.

So i've open this thread to ask to other customers 'how' they solved this issue.
regarding custom router: in your experiences, which is a good router, easy to set up, that 'works well' with Superhub 3 (in modem mode)?

NOTE: even if i consider this behaviour 'very strange' from the biggest provider in UK, i don't throw any comments regarding 'compel customers' to use a 'not working' router, and after 1 year 'never release' a working firmware.
And i don't blame the VM technicians, engineers, or call center operators, since this is an Hardware and firmware issue.
And i'm sad thinking that those persons, every day, collect complaints from customers, and they would to do something, but they can't.
And they are daily embarassed for this.

0 Kudos
Reply
  • 6.23K
  • 481
  • 1.03K
Tudor
Hero
2,574 Views
Message 2 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

Just you wait until we get IP6!


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
0 Kudos
Reply
  • 12.61K
  • 482
  • 1.12K
legacy1
Alessandro Volta
2,567 Views
Message 3 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue


@marcixxx wrote:

So at this point i have only 2 solutions.
1) Buy my own router, and set up the Superhub 3 in 'modem mode'.
Then use my own router and set it for a 'safe' port forwarding.


Yes do that.

 also here's how to change RDP port

https://support.microsoft.com/en-us/help/306759/how-to-change-the-listening-port-for-remote-desktop

 

0 Kudos
Reply
  • 9
  • 1
  • 1
marcixxx
Tuning in
2,541 Views
Message 4 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

Thank you @Tudor for your reply.

But sorry, honestly i don't understand, what does it matter, the ipv6 with 'Superhub 3 firmware, port forwarding issue'.

0 Kudos
Reply
  • 6.23K
  • 481
  • 1.03K
Tudor
Hero
2,537 Views
Message 5 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

It all depends on how VM use IP6, if they use DS Lite there is going to be a lot of trouble for people with their own modems, port forwarding does not exist on IP6.


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
0 Kudos
Reply
  • 9
  • 1
  • 1
marcixxx
Tuning in
2,532 Views
Message 6 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

Thanks @legacy1 for your reply.

Yes, i know already that is a good solution change the rdp listening port.

But to help some customers that don't understand why do that, i'll add some brief notes.

Internet it's full of 'hackers bot' that continuously 'sniff the web' searching for computers to infect.

One of the main purpouse of these hackers it's to find computers to infect and use them as 'zombie's pc' to use in later massive ddos attack.

And usually those hackers bots, scans the web trying to access from port 3389, that usually it's opened by default as it's the remote desktop port used, on all Windows based systems.

And as you suggest, a basic safety advice it's to change the rdp port in the mode you explained.

And obviously after changed it, you should go in the 'Windows Firewall Advanced Security' panel, and disable 'ALL' the default rdp rules (There are more than one to disable, by default seems to me at least 6).

And you have to create your own 'Windows Firewall custom rule' that allow an rdp connection 'only' to the port of your choice.

Hope this could be in help to other customers.

...But...@legacy1

Please, what is your router?

Did you had particular problems with Superhub 3 used in 'Modem mode'.

I have more than 1 pc to connect: do you know if your router 'works' with more than 1 pc connected, when it's used with Superhub3 in modem mode?

Do you know in particular a good router that is suggested to use with Superhub 3?

Thanks

0 Kudos
Reply
  • 9
  • 1
  • 1
marcixxx
Tuning in
2,522 Views
Message 7 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

Thanks again @Tudor.

But again, sorry, but i don't understand what you say.

Please, help me to understand.

What is DS Lite?

And why you said '...depends on how VirgimMedia use ip6...'???

To be clear for others customers that could read:

Virgin Media is a company, one of the biggest provider in UK.

ipV6 it's a protocol to transfer data.

Modem/router are hardware that allow a computer to connect to the web.

Inside a Modem/Router there is a software (firmware) that allow to manage the data between computers and the web

In particular the current standard Modem/Router 'user interface', allow a customer to set up the Modem/Router through a webbrowser instance executed in a terminal, inside or outside you local network (depending on the Modem/Ruter' settings).

And throught the software you could be able to set particular rules depending your needs, and in particular also rules related to IP/IPV6 protocol.

This is a standard for all the Modem/Router currently existing.

And because, Superhub3 have a firmware that have a 'bug' that after more than 1 year is still unfixed (and this appear obviously for everyone that try to set up a PortForwarding custom rule, and it's also confirmed by technician and VM engineers), honestly I still can't understand what you mean...

0 Kudos
Reply
  • 12.61K
  • 482
  • 1.12K
legacy1
Alessandro Volta
2,519 Views
Message 8 of 19
Flag for a moderator
Helpful Answer

Re: Superhub 3 port forwarding issue


@marcixxx wrote:

...But...@legacy1

Please, what is your router?

 


My router is complicated but basically I have a Zyxel ZyWALL 110, USG 60, 40 and a Ubiquiti EdgeRouter Lite.

These are not your average routers but for a home router you could go for this.

https://www.amazon.co.uk/dp/B01M1BZ7FY/ref=psdc_430579031_t3_B00YG1BHG0

many others will suggest other makes.


@marcixxx wrote:

Did you had particular problems with Superhub 3 used in 'Modem mode'.


don't have a hub 3 but you should have no problems either way to use modem mode

  • 9
  • 1
  • 1
marcixxx
Tuning in
2,514 Views
Message 9 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

Thank you very much @legacy1.

You have been very helpful.

0 Kudos
Reply
  • 3.47K
  • 111
  • 417
VMCopperUser
Trouble shooter
2,501 Views
Message 10 of 19
Flag for a moderator

Re: Superhub 3 port forwarding issue

Some of your arguments about how things work and don't work are wrong. 

If you have 3 computers that all want to listen on the same IP then there are no routers you can buy that will make this work on IPv4.

The feature is not possible.

Legacy said in post 3 how to change your RDP port.

All you need to do is change it so each device has it's own port, then set up a forwarding rule for each device.  I think your over complicating the issue.

The SuperHub is not the problem here.

----
I do not work for VM, but I would. It is just a Job.
Most things I say I make up and sometimes it's useful, don't be mean if it's wrong.
I would also make websites for them, because the job never seems to require the website to work.
0 Kudos
Reply