Menu
Reply
  • 12.92K
  • 366
  • 1.04K
Moderator
Moderator
5,579 Views
Message 11 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

Hi WaspAttack,

 

Thanks for posting, did any of the advice offered above from Nex help get your TP Link home plugs connected, notably changing the security mode?

 

Have you tryed manually set the homeplug to the same SSID/passphrase?

 

Keep us posted with how you get on.
 

 

 

Ralph_R
Forum Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply
  • 2
  • 0
  • 0
TODD12
Joining in
4,775 Views
Message 12 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

It's easier to do it manually. I tried to use the WPS button for ages but couldn't get it to work so just look at the back of the TP-LINK4220 and you'll see it has it's own password, just put that into your PC/Tablet/Phone instead.

0 Kudos
Reply
  • 2
  • 0
  • 0
Trevsweb
Joining in
4,586 Views
Message 13 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

Hi, having the same issues here too. 

given up on WPS connecting but can't seem to connect to my tp link powerlines anymore. I've tried resetting them and directly connecting to them but nothing is working. I cant get to the backend anymore to do the manual connection.

 

Anyone shed some light on this.

0 Kudos
Reply
  • 2
  • 0
  • 0
Trevsweb
Joining in
4,581 Views
Message 14 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

Managed to reset the devices one by one. and get them paired to the main hub. now manually renaming the ssid and changing the wpa codes
0 Kudos
Reply
  • 24
  • 0
  • 0
dizwod
Joining in
4,019 Views
Message 15 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

I got these yesterday and couldnt clone with the WPS.

 

manually edited the SSID and phrase. Works a treat. Half signal without extender on and full with it on.

 

WPS never really works for me in the past so why bother now Smiley Very Happy

0 Kudos
Reply
Highlighted
  • 1
  • 0
  • 1
ianwalls
Joining in
3,965 Views
Message 16 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

Cloning the TP Link wasn't working for me. I made one change to the SuperHub settings and it worked immediately:

Log into your SuperHub. Click 'Wireless Network Settings'. I changed 'Security Mode' from 'WPA2-PSK/TKIP' to 'WPA2-PSK/AES'.

That's it. The only change I made. I then did the WPS scan from the settings page rather than the big button on the front of the SuperHub.

Go to: Advanced Settings > WPS Settings > WPS Sync. Then press the clone button on the TP Link for two seconds. You should very shortly get the message: Add Client Status Success!

  

Good luck!

  • 2
  • 0
  • 2
Liverlad
Joining in
3,871 Views
Message 17 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

Thanks to Ianwalls,

What he says here really does work not even Virgins Technical support could figure a way to correct this problem and when I explained to Virgin what Ian said to do they were amazed. The tech support agent said she was going to make extensive notes and inform her supervisor about this as her supervisor had previously said that they could not help with TP LINK devices and their connection problems. When I explained that the Virgin website showed a video of connecting a Netgear powerline adapter to a Superhub the Virgin agent told me that's because Virgin now own Netgear.

 

Anyway here is how to clone your Virgin Superhub to your TP LINK Powerline Wirelessly.

 

First off all plug in your TP Link Powerline adapter and just incase you have made a mess of things reset the adapter by pushing a pin into the reset hole under the adapter next to the Ethernet sockets and hold it for about 5 seconds until you see lights going off. Now your Powerline adapter is reset to factory like when you took it out the box.

 

Next open a webpage on your computer assuming you have your Virgin Superhub up and running and type in the superhub address 192.168.0.1 and hit enter. If you do not get the Virgin Media Super Hub webpage up and it goes to Bing then you will need to contact Virgin Tech support as you have errors in your Hubs settings and they will correct this.

 

Now when you have the Super Hub page up it will ask for a settings password which should just be the phrase "changeme" This is written on the back of the Super Hub at the bottom under Super Hub Settings and next to Password:   changeme.

Then the sign in requires you to enter the WPS PIN which is usually an eight digit number like 02202854 or something similar  and again this is written on the back of your Super Hub about halfway down next to WPS PIN:  02202854 Then you need to click sign in and a pop up screen will tell you you can change your pin but just click ok on that and it will disappear.

Now you will see three large red icons    WIFI  Wireless Network settings  /    Super Hub Settings     /     Device Connection Status

Now you click on WIFI  Wireless Network Settings

You will see Wireless on off and then the next line you will see Security Mode and in the box next to it it will probably say WPA AUTO.

Now click on this Security Mode box and from the drop down menu select the selection WPA2-PSK[AES] and the scroll halfway down the screen  and click the save settings icon  (((((((WARNING WARNING  DO NOT CLICK THE GENERATE NEW WPS PIN WARNING WARNING))))))

Now near the top of the page click the Home icon which will take you back to the Home page with the three large red icons on it from before.

Now near the bottom of the home page is a red Advanced Settings icon click on this and a pop up Advanced settings warning will come up and just click on yes here not cancel (trust me don't worry about it)

Now on the advanced settings page the first grey box titled Wireless has 5 selections the bottom one being WPS settings and you should click on this.

Now be careful not to press anything and look down the left side of the screen until you get to a red icon which says WPS Sync which is under Add WPS Client and a selected Push Button.

Click on the red icon WPS Sync and then the page should keep reloading and it should say in progress. You will also notice the large button on the front of your Super Hub will flicker red pink purple colour DO NOT PRESS THIS BUTTON AT ALL.

Now go to your TP LINK Powerline Adapter and look for the WPS or wireless button on the front of the adapter at the bottom of the green lights in fact it will probably be flashing rapidly. Press this button and hold for say three seconds to be sure and release. It should now start to flash much slower and on your computer next to add client status it should say Success! If it says Timed out then click cancel and then Apply and close your browser and open a new page and goto 192.168.0.1 sign in and click on to the advanced settings and WPS Settings page and WPS Sync again and then press the WPS button on your powerline for 3 seconds again until you get Success!

It would appear that if you want to add/clone  more than one Wireless Powerline adapter then you have to have all close by so you can press the WPS button on all the adapters for three seconds at the same time although I have not tried this out yet.

Also if you want to add another adapter and you already have one running then you might have to reset the one you have running and sign into your superhub 192.168.0.1 go to Advanced settings and then WPS settings and next to Add Client Status where it says success click cancel next to it and confirm changes and click apply then sign out and open a new browser page 192.168.0.1 goto to Advanced settings WPS settings and click the Red icon WPS Sync and then press the WPS wireless button on each of your Powerline adapters at the same time if possible for 3 seconds so they will all clone at the same time.

 

The reason for this appears that the Large WPS button on the front of your Virgin Superhub that is usually lit up blue does not seem to work with cloning TP Link Powerline Adapters, it seems the button needs to be activated from the Advanced settings/ WPS settings/WPS Sync icon when you sign into your super hub from your computer.

Now you should be able to move your adapter to another socket somewhere else in the house and it should still be cloned. It just needs to be near the Virgin Super Hub to be cloned initially.

 

Hope this helps. I am no expert in fact I know very little about computers and all I have done here is explain in depth how to make your  TP-Link TL-WPA4220 clone with your Virgin Super Hub and hopefully make it simple to understand.

The real credit needs to go to IanWalls who got things to work in the first place where many others had failed including Virgin Tech support.

Lee

 

  • 2
  • 0
  • 2
Liverlad
Joining in
3,870 Views
Message 18 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

look at my post or Ianwalls its been worked out how to clone your TP-Link TL-WPA4220 to the Virgin Super Hub
  • 1
  • 0
  • 0
TQ_1
Joining in
3,486 Views
Message 19 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

I set mine up manually to start with using the broadcast web ip addresses and the tool that came with the set. The problem I have is that the Wifi network when connected to the superhub2ac runs really slow through the extenders? Ideas?

0 Kudos
Reply
  • 1
  • 0
  • 0
Fishy-
Joining in
2,526 Views
Message 20 of 20
Flag for a moderator

Re: Superhub 2 with TP-Link TL-WPA4220

Hi Lee, I have followed your instructions to the letter but after 4 attempts I keep getting the Timed Out Error. Not sure what I am doing wrong? I am sitting less than 3 feet from the device with my computer.

0 Kudos
Reply