cancel
Showing results for 
Search instead for 
Did you mean: 

RDP Issues

Brabian
On our wavelength

We've just returned from holiday and what was an occasional drop out has become a complete block: we cannot connect to my wife's company using RDP.

I've now spent hours with the broadband team (who did nothing) and the Rescue Gadget team (who completely failed) and STILL we cannot connect. 

Even doing a port check (portchecker.co) on port 3389 reports "CLOSED" (it was at this point that the Rescue guy quit!).

Now I know that this is a long-standing issue with VM and I don't know why it is, but using almost any other service (my own O2 hotspot, for example) works fine.

Does anyone know what the issue is and what, more importantly, the solution is?

35 REPLIES 35

Brabian
On our wavelength

No - I'm in the UK and so it's probably a Hub 5 that I have - don't know where the "6" came from!

Brabian
On our wavelength

Actually, I think I may have clicked "Helpful answer" somewhere along the line...

Brabian
On our wavelength

Actually, if you read the posts you'll see that the Hub is pre-configured to block this port so it is a VM issue! Otherwise, switching to modem mode and forking out for a router wouldn't solve the problem!

Client62
Legend

Does RDP work via a Hub 5 in Modem mode where there is no NAT & no firewall so no blocking ?

Well actually, I have read the entire thread, I always do before replying and I’ve not seen anything which hints that the Hub 5 is ‘blocking the port*’, perhaps I have missed something and you can point me to the relevant post!

But again, are we taking about outbound connections or inbound ones?

But have you considered this, switching to modem mode, changes the WAN IP address as seen by the remote system. Is it possible that the remote system has a block list of IP addresses from which it won’t allow connections and/or an allow list and the addresses in router and modem mode happen to fall into these categories?

* which port by the way? Outbound source traffic ports are ephemeral, effectively random.

legacy1
Alessandro Volta

@Brabian wrote:

switching to modem mode and forking out for a router wouldn't solve the problem!


Yes it will

---------------------------------------------------------------

Client62
Legend

Anyone permitting their WFH teams to connect directly via RDP over the public internet to the firms business server ?
No, I suspected not.

First ones people connect to the firms VPN and only then then via RDP if your a developer / sysadmin / DBA or similar.   But the key VPN step is missing here ... Why is that ?

the entire conversation is about people trying to make outgoing RDP connections which is being blocked by the router.  VM have confirmed over the phone that the only option is to use modem mode or downgrade to the earlier model router that doesn't do this built-in port blocking.  again, i'm not asking for anyone to decide for me whether the RDP protocol is secure or not, that's besides the point, it could be for any protocol/port.  the point is that it's not acceptable for VM to block outgoing ports without giving the user the configuration option for the internet services they want to use. 

i can confirm it's nothing to do with serverside IP whitelisting or any other potential network interference from other devices.  the VM router mode is the only cause of the issue.  it's not at all a complex issue, and the only frustrating thing is that after upgrading to the latest VM router to get wifi 6 i now need to turn off the router mode and go and buy a wifi 6 router. ☹️

timmer3_0-1689373930744.png

 

legacy1
Alessandro Volta

@timmer3 wrote:

the point is that it's not acceptable for VM to block outgoing ports without giving the user the configuration option for the internet services they want to use. 


 

That would be more true if modem mode did that but modem mode works fine in truth your only getting one WAN IP for true internet access VM did not have to add router mode and just because its there does not mean it has to work I'm sure over a million on VM don't use RDP and VM knowing it works in modem mode just go good enough.

---------------------------------------------------------------

Brabian
On our wavelength

As I mentioned, somewhere, Client62, my wife's RDP connection links her to a TeamViewer environment which is, effectively, the VPN step you are worried about!