Showing results for 
Search instead for 
Did you mean: 

Problem using the VM Connect app to do home broadband survey

On our wavelength

I have downloaded the VM Connect app and am attempting, with complete lack of success, to access the room-by-room home broadband check. So far the app is well in the running for the Chocolate Teapot of the Year Award; but enough of the moans.

After struggling through the opening pages I came to a complete brick wall that simply said, "You have no access to home broadband. Your account isn't set up to use home broadband." Really? No access? Am I imaging having been with this organization since Cable & Wireless days in the 90s.

OK, I thought, calm down. Just set up the account to use home broadband. Unfortunately there is a slight problem here in that the page didn't give the slightest hint on how to do this set up, nor did it show a way forward. Just a complete brick wall with no help in sight.

Please, please can someone suggest a way to way to move forward.

The reason that I want to do the house broadband check is that I'm having occasional problems with iPlayer, ITVx etc stuttering, or even refuse to play, which I'm fairly certain is due to a poor wifi signal - my router and the TV are as far apart as it is possible to be. Using the VM signal strength measure on the TV confirms this. VM have sent me a wired booster, but after a day trying to get it to increase the signal strength, and failing, I'm fairly certain it is not helping.

Before I get back to VM I'd like to have some figures, figures that would have been obtained with their own app, to quote at them.



"You have no access to home broadband. Your account isn't set up to use home broadband."

Use of VPNs or Apple Private Relay / Browsing Tools also Android DNS Changers are a common cause of not appearing to be on the home Wi-Fi network.

Very Insightful Person
Very Insightful Person

Do your "survey" using a wifi analyser App (or Airport Utility on iOS) this will be far more informative.

Re poor wifi and VM  - see this...

Do you know if its a wifi only issue (are ethernet connected devices ok?), if it is - then On a Hub3/4/5, you could first try separating the SSID's of the 2.4 and 5 GHz wifi bands by renaming them in the settings At the same time switch off "channel optimisation/Smart wifi” and “ apply and save the settings. All wifi devices will now need reconnecting to the best SSID at each location. Also use a wifi scanning App to find the best wifi channels to use (just select and use channels 1,6,11 on 2.4GHz) - this often helps Hub users get better wifi performance - so its worth trying - but its still no substitute for getting better kit 🙂

To address the wifi issues, VM now supply “wifi Pods” (no longer doing cheap and cheerless and poor value “boosters”). However, their Pods are only free to customers on the 1GB, Volt (or old Ultimate Oomph) packages - is that you? If so they are worth trying - they should work for you. VM Wifi is now “guaranteed” to 30 Mbps/room it’s now called… Wifi Max
See if anything in here helps….

You call 0800 064 3850 to order the first one after scanning for blackspots using the connect App.- or just wait here for a VM person to respond in a day or two and they will sort the first one for you. If you do call dont get fobbed off by the offshore CS agents' saying you aren’t eligible - you are - it is clearly stated on the webpage.

If not free to you… you will be charged £8/month for up to 3 pods (note - BT charge £10/mo for their whole home wifi solution). It’s a simple solution and should work for you. However, you would soon pay off that cost by buying your own wireless solution that will be yours to own and use forever, although the VM Pods should be a simpler option.

If you do want to invest in better equipment, you would need to get either a… (1) Mesh System, (2) Wireless router, (3) Wireless access point, (4) a pair of good quality Wifi Powerline Adaptors, or a combination of (2&3).

£40-100 (that’s ~4->12 months of Max Pod rental) should sort it for most customers with an average property and usage. Spend more for additional advanced“features” - if required.

See message 5 in this thread for how to connect Pods



I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Thanks for the reply. If I may reply point by point.

Para 1. Unfortunately most of this is well above my pay grade. That I had to google SSID says all you need to know about my level of expertise. But the main reason is that delving into the depths of the system would almost certainly be inviting catastrophic crashing of my system. I only need to remember the fear and trepidation which I felt once when I decided that I had to make some changes in the BIOS of my PC.

However, I do have a scanner app (just not the VM one) and changing the channels sounds like something easily reversible. I may have a go at this once I’ve googled how to change channels.

Para 2. No, I’m pretty certain that those packages or not me.

Para 3. Thanks for the link above with the promise for good reception in each room. I was going to rely on a vaguely remembered TV advert that promised this.

Para 4. I feel rather annoyed that VM would expect me to pay to get the service that I mistakenly thought I was paying for, but I suppose that my indignation cuts no ice with VM.

Para 5. Thanks, it gives me some starting points if I decide to go down this route.

However, back to my original request about Connect. I’m afraid that it was my mistake to add my final paragraphs as I now seem to have opened a question that I did not intend to do until I had sorted out the Connect bit, and for which I intended to start a new thread. My apologies.

The main reason I want to get Connect running is that it specifically has a room by room survey which I hope would give me better ammunition to use against VM. So if I can be told how to get Connect up and running it would be a start.

Thanks for the reply. However, I don't have any of the things you mention. My setup is plain vanilla. It looks like I may have to bite the bullet and phone 150 although, on much past experience, I put almost no hope in that approach.


Unless you will get the VM Pods for free i.e. part of your current subscription I would avoid them as they are bad value for money, very restrictive and the moment your Hub needs to be replaced as they will stop working.

There are many retail options that will work with any ISPs Hub / Router that represent better use of funds.

Thanks for the reply. I appreciate the comments about how it would seem that there are lots of things that are superior to VM equipment, but all of the alternatives will cost me money. My point is that I would like VM to make the service I am paying for work as advertised. Surely this is down to them, not to me.

Unfortunately I seem to have muddied the waters a bit by mixing what are really two separate questions. Let me try to get it back on track by trying to explain exactly what is happening – sorry about the length of the explanation.

I have a VM router upstairs with an Ethernet connection to my PC. I have a TV set and a VM TV box downstairs connected to VM by a fibre optic cable. As far as I understand it I get the listed TV programs via the cable, and that all the programs on request such as iPlayer, itvX etc go from the router to the TV box by wifi, If I’ve got it totally wrong, let me know and I’ll wipe the egg from my face. J

Until fairly recently I never used such things as iPlayer & itvX, but I am now using them more. What I find is that everything will be OK for a few weeks but then the programs will start intermittently freezing, then reach the stage of refusing to play at all together with some error message. Things will then start getting better and then the cycle will repeat itself. Using the Network Status service on the TV Box the best value for signal strength is about 40% (Marginal) and the worst has been about 25% (Poor).

I finally got totally fed up with this poor service and (this took a number of attempts via 150) finally got someone to take this problem seriously and not just rabbit on about resetting the router or checking the cables. They arranged to send me a pair of wired boosters.

I have only been using the boosters a couple of days, but as the problem only occurs every week or so I cannot yet definitely say whether or not there is a still a problem. However there is definitely something going wrong with the boosters.

Firstly, the app (WifiAnalyzer) on my phone gives the signal strength as varying between -70dBm and -80dBm near the TV set. (It’s -40dBm to -50dBm next to the router). When I switch the booster on and off it’s very difficult to say whether this makes any difference to the signal strength.

Be that as it may the boosters are definitely not behaving as the manual says they should. I connected one booster to the router via the ethernet cable and plugged the other booster into a mains socket in the same room. As detailed in the manual I pressed the Sync button on the router booster for 3 sec then pressed the Sync button on the other booster for 3 sec. I seemed to get the solid white power light and no red connection light as per the manual. I took the latter booster downstairs and plugged it into a socket in the room next door, but only a few feet from the TV. It appeared to settle down to a solid white power light and no red connector light, which the manual says is normal. However, not long after this changed to a permanent blinking white power light which the manual says means it is copying settings from the router. This never stops. Meanwhile the router booster now shows a solid white power light and a flashing red connection light which the manual says it is saying that it is ready to pair. My interpretation, which is quite possibly wrong, is that the router booster is failing to pair with the booster downstairs. Who knows, I definitely don’t and am at a complete loss.

My reason for starting of the request with a plea on how to get the VM Connect app working was that as it allows a room by room check I would get some reults using a VM app so that I would have something to argue with if I contact VM again.

The problem at the moment is that speaking on 150 to VM normally only gets you someone who goes around the “reset the router” loop. There is no VM email address or chat line that I know of. VM seem to insist that all anyone can do is use this forum. I have used it in the past and eventually you get an answer. So here I am.

Hi @Melvil_Dewey,

Thank you for your posts and welcome back to our community forums. We're here to help.

I'm so sorry to hear that you're experiencing some issues with your Wi-Fi connection and that unfortunately the Connect App isn't helping to diagnose/assess the situation further. I can see from your posts that you've tried a few things, including using a booster, which sadly haven't aided things.

Just to clarify, is it only the one TV that's having problems with the Wi-Fi connection, or are other devices also displaying some problems? Have you been able to begin using the Connect App yet? If not, would you mind providing a screenshot of the error message that's appearing which you mentioned earlier?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

On our wavelength

Thanks for the reply.

Yes, there is only a problem with one TV and the problem is only with services such as iPlayer, which I assume are sent by wifi from the router upstairs to the VM TV box downstairs. Signal strengths, given by the, I assume VM TV box, and appearing on the TV screen vary from 25 to 40% (poor to marginal). The TV programs will be OK for a few weeks then either stutter, or refuse to play at all, for a few days, then start playing OK again. Signal strengths next to the TV, measured on the WifiAnalyzer app on my phone, vary between -70 to -80 dBm, which I gather is not very good.

A screen gab from VM Connect on my android tablet is attached. The error message appears when I press the Broadband icon near the bottom of the screen on the Home page. The VM Connect app on my android phone gives the same error message.

Regarding the booster, I’m still trying out some tests but the results so far are not very encouraging. According to the booster manual there is only one sure sign of success; a solid white power light and the connection light off.  A fair number of trials have shown initial success followed by the white power light blinking slowly, which the manual says means copying settings from the hub. At the same time the Connection light on the second booster directly connected to the router flashes red, which the manual says means it is ready to pair (but never does). This failure of synchronization occurs after 10 minutes or so if the booster is near the TV, and after around an hour or so if the booster is about 10 feet from the router in the room containing the router.

The main reason for wanting the VM Connect app was to allow me to quote results obtained with a VM app, especially these room to room measurements, in an attempt to get the TV problem sorted.

One final thing. My house is your standard semi so distances are pretty average; no attempt to connect the maid’s room in the east wing attic with the kitchen in the west wing basement in a stately home. I seem to remember a recent VM TV ad that made some claim about good connection in all rooms of the house.Screenshot_20231007_143848_VM Connect.jpg

Very Insightful Person
Very Insightful Person

The best way to permanently fix the network connection problem on the TV is simply to run an ethernet cable from its port and connect it to the Hub.  Job done!  Same for any other devices that require a stable network connection  

Wifi is the work of satan 😎


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.