Menu
Reply
elizab
  • 4
  • 1
  • 1
Tuning in
98 Views
Message 1 of 3
Flag for a moderator

Problem loading a specific website

I'm having problems installing any of microsoft visual studio applications due to the apps not being able to communicate with a few key microsoft servers.

I tested the url in my browser manually and it just hangs at connecting.

Known problem url: https://aka.ms/vs/17/release/channel
It redirects to a https://download.visualstudio.microsoft.com

The domain isn't blocked though because https://aka.ms loads/redirects fine and so does the subdomain of microsoft's website.

I have tried everything possible on my end and came to no solution (disabling firewalls/protections, using custom google or quad9 dns servers, made sure virgin websafe was disabled, resetting windows network adapters and reinstalling.. etc).

The only time i can get it to work is if i tether my phones internet connection while disabling the phones wifi so it uses the mobile data connection but that's not efficient due to speed limitations and bandwidth usage (it rules out my computer being the issue though).

Any help or assistance would be greatly appreciated.

Many thanks.

 

0 Kudos
Reply
Cardiffman281
  • 1.21K
  • 85
  • 254
Knows their stuff
87 Views
Message 2 of 3
Flag for a moderator
Helpful Answer

Re: Problem loading a specific website

elizab
  • 4
  • 1
  • 1
Tuning in
78 Views
Message 3 of 3
Flag for a moderator

Re: Problem loading a specific website

Ah yes it could be the CDN having issues with certain connections/routing, that makes sense. I'll monitor it for the time being, thanks.