Menu
Reply
  • 8
  • 0
  • 0
Jordanw583
Joining in
484 Views
Message 1 of 14
Flag for a moderator

One device being denied internet access?

My huawei p20 pro has been fine for as long as I can remember with using the internet from upstairs, however revently it just frequently says, "connected (no internet access)" and I have to forget the network and type in the password to connect again. 

It works when I'm downstairs but when I go up it loses connection again at random points. It works fine when connected to a different Wi-fi however

0 Kudos
Reply
  • 511
  • 32
  • 34
Forum Team
Forum Team
450 Views
Message 2 of 14
Flag for a moderator

Re: One device being denied internet access?

Hi Jordanw583, 

 

Welcome to the forums. 

 

I'm sorry to hear of the issue you've seemed to have picked up recently. How long has this happened for? Also, have any more devices been connected in the time it seems to have changed? 

 

Keep me posted. 

Ryan_N - Forum Team
0 Kudos
Reply
  • 8
  • 0
  • 0
Jordanw583
Joining in
436 Views
Message 3 of 14
Flag for a moderator

Re: One device being denied internet access?

This has been happening for about 10-14 days now, and yes, theres about 10 other devices, like phones, consoles, laptops and tablets all connected to the same network but its only my phone losing internet access. This problem only seems to occur with my phone. Once I turn off my network carrier to manuel, its completely fine, but it automatically turns itself back on and the problem comes back (Im with Vodafone if that helps)

0 Kudos
Reply
  • 2.54K
  • 98
  • 175
Forum Team
Forum Team
435 Views
Message 4 of 14
Flag for a moderator

Re: One device being denied internet access?

My apologies. 

 

Do the other devices have any issues?

 

Kind regards,

John_GS
Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - "How to pay my Virgin Media bill"

0 Kudos
Reply
  • 3.93K
  • 466
  • 1.26K
Very Insightful Person
Very Insightful Person
428 Views
Message 5 of 14
Flag for a moderator

Re: One device being denied internet access?

I have moved your thread from the gaming board to the WiFi board as it seems a more relevant place for your issue, I hope you don't mind.

This thread on Reddit suggests the P20 has wireless issues with a few ISP routers and there is mention of an Android update breaking WiFi on some Samsungs until a fix was released:

https://www.reddit.com/r/Huawei/comments/8n7lvw/huawei_p20_pro_wifi_connectivity_issues/

Has the OS on the phone been updated recently?

______________________
Scott

Disclaimer - I don't work for Virgin Media. I'm just another VM user trying to help out so my answers may be wrong Smiley Happy If my answer solves your problem please mark it as helpful as it may help others
My setup: Vivid 200 Optical fibre with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

 

Mark as Helpful Answer if I've helped

0 Kudos
Reply
  • 9.01K
  • 925
  • 1.4K
jbrennand
Alessandro Volta
425 Views
Message 6 of 14
Flag for a moderator

Re: One device being denied internet access?

What Hub model do you have? If a Hub3 and you havent already tried it, try renaming the SSID's of the 2.4 and 5 GHz networks and disabling "channel optimisation" and then connect the phone to each of them individually.

--------------------
Services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired 2 WiFi,) SH2 in modem mode with Airport Extreme Router. On VIVID200, Talk Anytime Phone, x2 Mobile SIM only iPhones.
0 Kudos
Reply
  • 8
  • 0
  • 0
Jordanw583
Joining in
406 Views
Message 7 of 14
Flag for a moderator

Re: One device being denied internet access?

Nope, just my phone

 

0 Kudos
Reply
  • 8
  • 0
  • 0
Jordanw583
Joining in
405 Views
Message 8 of 14
Flag for a moderator

Re: One device being denied internet access?

Yes actually, recently it's been updated to EMUI 9 (Pie) but this didn't take effect immediately, about a week or two after updated, the problem started

0 Kudos
Reply
  • 8
  • 0
  • 0
Jordanw583
Joining in
404 Views
Message 9 of 14
Flag for a moderator

Re: One device being denied internet access?

As of right now, the phone is fine, but once the problem comes back (if it does I'll disable the channel optimization) and I'll see if it works, I did disable both GHz channels but that didn't help, thanks for the input anyway!

0 Kudos
Reply
  • 3.93K
  • 466
  • 1.26K
Very Insightful Person
Very Insightful Person
386 Views
Message 10 of 14
Flag for a moderator

Re: One device being denied internet access?


@Jordanw583 wrote:

Yes actually, recently it's been updated to EMUI 9 (Pie) but this didn't take effect immediately, about a week or two after updated, the problem started


Not a conclusive "smoking gun" but as none of your other devices are having issues, it does suggest that the issue lies with the P20 rather than VM's kit. Maybe asking Huawei for support rather than VM would prove to be more fruitful.

______________________
Scott

Disclaimer - I don't work for Virgin Media. I'm just another VM user trying to help out so my answers may be wrong Smiley Happy If my answer solves your problem please mark it as helpful as it may help others
My setup: Vivid 200 Optical fibre with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

 

Mark as Helpful Answer if I've helped

0 Kudos
Reply