Showing results for 
Search instead for 
Did you mean: 

New Hub 5 appalling internet connection and unable to connect devices

Tuning in

Received new Hub 5 and set it up.

Now, unable to receive stable internet connection and devices don't recognise WIFI, such as previously connected TP Link smart plugs and Alexa devices. All of which were connected to previous HUB 3.  

Ipad shows, when connection, 433mbps.

white light, bottom right hand side of HUB, solid white.

Moved HUB from near TV, where previous HUB was situated, to table top with no obstructions and no improvement.  

Net Vue CCTV cameras, that were connected to previous HUB, have re-connected, but when trying to add a new camera, no internet connection found.

Message appears that signal shows as 5Ghz and cameras need 2.4 Ghz only.

Keep getting messages, from Virgin media, to return old HUB to Virgin media, but I actually want old HUB reinstated as all home equipment worked fine then.

Tried re-connecting previous HUB but it appears Virgin media have disabled it.

Does anyone know of a work around / action to take to correct please ???

Virgin media, if you are monitoring, what's going on ??????




Tuning in

Can anyone advise please...

problems with new HUB 5, as previous post.

How can I get HUB 5 to only be 2.4 Ghz ?

What settings, basically how do I do this as not overly tech savvy....

Thanks in advance for any help (and with any support on earlier post).





Very Insightful Person
Very Insightful Person

Split the SSID as below and manually choose which band to connect to.

• Access your Hub by navigating to
• Login with the default login info (on base of Hub) unless you've already updated it.
• Go to Advanced Settings > Wireless > Security
• Under Wireless Frequency 2.4GHz change the Wifi Network Name (SSID), suggest append _2 to the end.
• Repeat for the Wireless Frequency 5GHz, suggest append _5 to the end and click on Apply changes
• Try to avoid spaces and periods in the SSID names as they can cause issues with certain devices.


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Very Insightful Person
Very Insightful Person

Hi @Silverfox0303 

I've merged your posts together.

I have the hub 5 and have renamed my 5GHz connection so that connected devices can choose between 2.5GHz or 5GHz.

Open a browser and log into your hub - then navigate to the following settings so you can differentiate between the signals.

Go to Advanced Settings > Wireless > Security > Add  5G to the 5 GHz Channel name (eg VM 12345678 becomes VM123456785G) and click on Apply Changes.

You can leave the passwords the same as they are.  Then log out of the hub at the top of the page

You will need to reconnect all you Wi-Fi devices some will want to connect to 5Ghz and some to 2.4GHz and some will connect to either.


You could also do a search for an app such as wifi analyzer which tells you the strength of the channel you are connected on, and also shows other channels so you can decide if you want to change the channel number on your hub to improve your signal

Advanced Settings > Wireless > Wireless Signal >  beneath both the 5Ghz and  2.4GHz sections click on the Manual button, and in the drop down box click on the channel number you want to change it to, then scroll down and  click on Apply Changes.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Hi Silverfox0303

Welcome back the community!

Sorry to hear you're having some HUB 5 issues at the moment.

Both @Adduxi and @newapollo have explained the way you can split your bands to connect your devices to the bands they're most compatible with. If you have any further issues please let us know and we'll be happy to assist further.

@Adduxi and @newapollo - Thanks for helping 🙂

Here to help 🙂
Virgin Media Forums Agent


Now the probable solution here is exactly as you stated yourself, you need the Hub 3 reinstated on your account and the 5 to be returned. Possibly splitting the bands might help, but did you have to do that on the older hub? If no then it points to an issue with the way that the Hub 5 handles WiFi.

My advise would be to contact VM and request that the older Hub 3 be reactivated on your account, they will need the MAC address and/or serial number from the sticker on the base. Now most likely, you will be told that 'this can't be done', 'it's impossible because pixies came out in the night and replaced the cables with special ones made from Unicorn hair which won't work with earlier hubs' etc.

In this case, just politely tell them that you know they are lying, ring off and then call back and follow the thinking of leaving us options. Tell them that the equipment they supplied is 'not fit for purpose' and you request/demand that they reinstate the Hub 3, which luckily you have kept.

Hi Silverfox0303…..I’ve got the same problem but before I go off trying one or both of the answers you were given by Adduxi and newapollo, did either of them work for you?

Unfortunately nothing worked with the new Hub 5, so eventually had VM switch me back to my old Hub and, after hours of resetting all connected equipment, managed to get things back to working.

Hi Silverfox0303, 

Thanks for coming back to us and updating your thread. 

We're glad things have since been resolved for you now. 

If you have any further issues with your old hub, please pop back and let us know. 

Many thanks, 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi there,

I have exactly the same problem with in particular a Google Nest Doorbell (Battery) which was bought and installed in November 2022. All was fine until about 2 weeks ago when it went offline overnight.

My HUB 4 had reset the wifi network SSID's to identical names and enabled "Smart Wifi" channel optimisation.

Initially the channel optimisation could not be disabled again (it was "greyed out") - now this setting is available again but makes no difference - more importantly I cannot now "see" two separate networks (2.4 and 5ghz) even with different SSID's assigned. Only one frequency at a time will now show up  - I did somehow manage to get 2 to appear and connected all devices to 2.4ghz , then disabled 5ghz - but this was just not usable, devices (mainly laptops) constantly disconnecting and pitiful network speeds - especially considering I pay a lot of money for the GIG1 service ! 

I now have a 3-4 month old perfectly functioning £180 Google doorbell which I cannot use thanks to some sort of update at Virgins end which will not allow both frequencies to be used independently ?? Having spent hours speaking to Google, then Virgin ( who seemed to be telling me it's all to do with smart / Mesh wifi ) and online researching how to fix it - it appears there is no fix unless virgin can send me a old router  ...