Showing results for 
Search instead for 
Did you mean: 

I need to order a WiFi pod!

Joining in

I'm going round in circles here...
I have recently upgraded to the 1gig volt package.
I have set up the new hub 5 router and have good reception close to the Hub 5, but have poor WiFi in the kitchen at the back of the house.
In 'my virgin media' account it says to order from the VM connect app...
The VM connect app says go to 'my virgin media' account and order a WiFi pod?
The contact phone number rings out for ages....
How do I get one?
Screenshot_20231001_113152_VM Connect.jpg


Community elder

The connect app didn't work with the hub 5, don't know if it's supposed to be fixed.

You can either call Virgin on 150 from a Virgin phone, mobile or landline, or 0345 454 1111 from any other phone to report a fault, or wait here for one of the forum team to pick this up which might be 2 to 3 day's.

When phoning choose the option to report a fault, then ignore all the options offered and you should then be placed into a queue to speak to someone.

Community elder

I would also like to add that the connect app used to work with my hub 3 then stopped working, error at Virgins end.

Tried all the Virgin suggestions, delete and reinstall, clear cache, reboot the hub, it used to work on both my phone and the OH's phone, since it stopped working both phones have been replaced and the connect app freshly installed and still get the same "Error at our end".

The message at the end "We can't find the hub"  "we can only see your devices when connected to the hub"

Well it's connected to the hub that's how my phone generally works.


Hi roy247,


Have you made any changes to your networks SSID's or passwords etc this can cause issues. Can you also send me a screenshot of the error message received and the devices used along with software details please?


It may not be related or the reason for your problems but there is an issue with iOS 17 and the connect app that is being looked into at present.



Hi Rob,

Screenshot below is from my Xiaomi pad 5 running android obviously and everything is up to date. Same message all 3 devices, tablet and 2 phones, android 13. Suddenly stopped working before I replaced the previous 2 phones. Don't have an exact date because it's not something you need to use much.

I have made no changes to my hub settings between it working and not working, as I said hub has been rebooted and the app reinstalled.




Hi roy247 👋

Thanks for posting a further update on this issue, as well as the screenshot. I'll ensure these are passed to our App Team, so we can look into this further. We are aware of an issue identical to yours that is affecting some devices, it is caused by an error in the data on one of our backend systems that our teams are investigating, so this may be linked.

I'm going to send you a private message, so we can look into ordering you a Pod. Please look out for my message in the top-right, white envelope or by tapping your profile picture, and then "Messages".


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Hi Reece,

Not received a PM but it's not me that wants to order a pod it's davethefish the original poster of this thread.

Thanks for the offer. 👍



Hi roy247 👋

Apologies! I'd misread the initial post you and davethefish made. I've gone ahead and sent davethefish a private message, so we can assist them further.

Thanks for letting us know 🙂

Reece - Forum Team

New around here? To find out more about the Community check out our FAQ