cancel
Showing results for 
Search instead for 
Did you mean: 

Hub5 connection timeout

AlphaFoxtrot
Tuning in

I’m experiencing some connection timeout issues with the new Hub5 and spent hours on the phone virgin media support to no avail. I’ve failed to get technical call backs that I’ve been promised and just been handed over to the “gadget rescue” department who required 3 attempts to just take my phone number. They’re clearly not the right department for this type of issues, but getting through to the right people is impossible. So I’m left with a router that doesn’t do its job.

Because I’m currently unable to fully utilise the service I’m paying for with the VM supplied hardware I thought I’d drop a note on here in the hope that I get to speak to somebody half technical at VirginMedia. Otherwise maybe this just serves to let others feel like they are not alone if experiencing similar issues.

The problem all started when I received the new hub 5 router. I ran in a to trouble connecting to some AWS document DB servers located in east-1 region. I started by running a dig with trace that resulted in a connection timeout after reaching the penultimate nameserver (ns2.amzndns.org). This all worked on my previous hub4 without issue. I can also connect just fine from the same machine with other internet providers (mobile hotspot). I tried disabling all firewall options on the router, attempted to turn off websafe settings on my virgin account (i can’t turn this on or off, but it appears off), resets etc. Finally I found that if I put the router in modem mode it works just fine. 

The issue seems to be with router dropping certain connection. Maybe do with the number of hops, maybe firmware related or some setting hidden behind the simplified admin interface?

I know I’ve not provided specifics such as the server address that I’m trying to reach. That’s just because I don’t want it on a public forum, but have shared such details with VM. If I ever get a response from them or a better solution I will be sure to update. 

5 REPLIES 5

Tudor
Very Insightful Person
Very Insightful Person

It’s all probably due to the VM DNS servers and the hub change is probably coincidental. If you want to use router mode not modem mode then put a DNS server, say 1.1.1.1 or 8.8.8.8 into you devices to override the VM DNS servers.


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Thanks Tudor. I should have mentioned I tried that also. Even if I force a specific DNS I get the same result via the VM router. When connected via WiFi or Ethernet. Router doing something very strange. 

Also if I list DNS servers that are auto assigned from the hub I get the same results in either router mode and modem mode. But modem mode works

Client62
Legend

Another instance of a Hub 5 in Router mode that is timing out on DNS queries for some AWS hosts and again it happens regardless of the specified DNS.

This has been reported before and the DNS tampering / blocking occurs only on Hub 5s in Router mode. For the IT Professional working from home the easy fix is Hub 5 in Modem mode + Router & even using the VM DNS the AWS hosts will resolve. 

What is the more serious problem is a commercial service delivered on the affected AWS platform may not be reachable by some perhaps all domestic VM customers that have a Hub 5 in Router mode.

What is it about resolving the DNS queries for these AWS hosts that differs from the norm ?

These are my exact thoughts too. Given half the internet is hosted on AWS, this must be making some services for some people unusable. 

It’s costing people to find solutions where there shouldn’t be a need to do so. 

Hi @AlphaFoxtrot thanks for your post here in the Community although we're sorry to hear of the concerns you've raised here.

I've ran some checks and there are some issues with the power levels to your Hub which may cause some performance issues.

Please allow me to send you a PM so I can look into this further for you, kindly expect the PM to arrive shortly and respond directly when you can!
Many thanks

Tom_W