cancel
Showing results for 
Search instead for 
Did you mean: 

Hub 3 red light and intermittent speed and connection

GemmaC4
Joining in

Hi, 

My Hub 3 has had a red light for the last few weeks and in the last week I've had much worse signal  around my house, the speed has been really intermittent and I've has several dropped connections in the last few days. 

I've restarted the hub via the app and the pin hole on the back but it makes no difference. The customer service rep I chatted to said that the red light is because it needs an update but that the updates are automatic so couldn't tell me when it will be done. This doesn't sound quite right to me! 

From other forums/questions it looks like this could be overheating and the hub needs to be replaced. Can anybody help?? 

2 REPLIES 2

RT123
Dialled in

Hi,

Yes - the red light is a sign of overheating and the hub needs replacing.

You can either wait for a reply here (probably at least a few days) or contact Virgin on X (@VirginMedia)/Facebook (I've found the social media team to be more helpful than phone/chat CS)

I do not work for VM, just trying to help!

Matthew_ML
Forum Team
Forum Team

Hey GemmaC4, thank you for reaching out and I am so sorry to hear this.  Also a very warm welcome to the community.

I am going to send you a DM but please do try these steps in the meanwhile;

• Turn the power switch off on the back of the Hub.

• Ensure the Hub is upright, in a well-ventilated location, and, if at all possible, out of direct sunlight.

• Then use the power switch to turn the unit back on. The Hub should now operate normally.
 

Matt - Forum Team


New around here?