Showing results for 
Search instead for 
Did you mean: 

Forced to clone laptop mac on Ax50 with hub3

Tuning in


I have Virgin 500 Broadband Hub3 set in Modem only mode with TP-LINK Archer AX50 connected to it in modem mode, not access point. All been ok for as lo g as ive had it, until notice not getting near the 500 (or better) which i did early on.

I know virgin have done recently work in my area, and I have reboted it all, but the problem preempted this work about a week ago anyway. 

So I connect direct to Hub3 in and out of modem only mode and speeds are fine both wifi and ethernet, so indicate issue with ax50. However when switching Hub 3 back to modem only mode and trying to connect to the Internet via the ax50 again, it wouldn't.

Did reset, hard reset all to no avail, then randomly started to look at other settings I'd never had to use and randomly clicked the Clone Current Device Mac in the AX50. At this point I had my work laptop connected via ethernet, as during this testing I used it as it has WiFi 6, so the only device that gets the full benefit of the ax50, but it is, other than this point, only ever connect via WiFi. 

So this 'fixed' the immediate isue and was back online, speed check the devices like the xbox and all improved back to top end speeds.

So I, stupidly, turn off cloning again. Bang, off line goes the ax50 and all connected to it.

Tried re-adding cloning via tether on my mobile but this didn't work, only worked again when I did it via the same work laptop again.

So I'm now back online with my work laptop ethernet Mac as the clone.

So the question here is why am I having g to clone to this this Mac (or any as i hand ever had to preciiusly, I's this a Virgin faullt or tplink fault?

I did read just Virgin (and apparently other networks may participate in this too) not liking people using modem only mode and adding their own better kit (so my answer then us improve your kit Virgin, as I've had to do this at my expense due to your incompetent hub3 not coping with the many devies and size of property and thus not coping with modern day demands) and its something they do now, by making you use a particular recorded Mac, in this case the ones used to do these tests and swtcih between modem modes.

So is there any truth in this, how do I revert back to not requiring this? 





Alessandro Volta

Do you have firmware version 9.1.2109.200 for the hub?

So with the clone MAC option everything works?

Their are many tests I can give you to do like put the TP-LINK Archer AX50 WAN MAC on your PC NIC connect it to modem mode and see if that works VM network to allow a new MAC is hub powered off for 2mins.

Other reasons is some else is using your MAC unlikely but could happen or the IP you get on by that MAC was removed from routing and the DHCP is not giving you a new IP that a change of MAC would do.

or could be that the TP-LINK learns how your PC does DHCP for it to do Unicast flag which by default on the TP-LINK does Broadcast flag.


Alessandro Volta

There is no need to do any cloning, and you should factory reset the AX50.

With the hub in modem mode connect a device such as a laptop and check your speeds. If all looks good connect the AX50 to the hub and reboot the AX50, connect the laptop to the AX50 with an Ethernet cable and check your speeds again.

Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection

How the heck does this help the OP? He’s not asking about speed testing.

Joining in

I have different kit but the exact same problem yesterday. After 5 years of owning a VM Hub (v2, v3 & currently v5) connected to a Linksys Velop tri-band mesh network, I`ve had to factory reset my entire setup around 5 times for various reasons and each time never any issues. Yesterday I did the same thing & the VM hub just would not connect with the Velop hub, it drove me crazy after 2 hours of factory resets and trying multiple options I gave up and called Linksys support who were excellent and took me through the process of mac cloning my laptop address, and everything started working as it should. But I never had to do that in the past so I assume Virgin has changed settings are their end. I was so **bleep**ed off after wasting around 4 hours of my Saturday because of VM. I searched all over for info on this issue and found little to nothing of help & certainly nothing from VM themselves. Are you still mac cloning?