Menu
Reply
  • 7
  • 0
  • 0
clubby789
Joining in
776 Views
Message 1 of 12
Flag for a moderator

Can't forward port 27015

I'm trying to run a dedicated server for the game Garry's Mod. The server works correctly (indicated by the fact that it works when I connect using my local IP) but I cannot connect to it via my public IP even though I have forwarded the relevant port (27015 TCP and UDP). I've been looking all over the internet for a solution but haven't yet solved it. I have a Super Hub 1. Can anyone help?

0 Kudos
Reply
  • 1.98K
  • 83
  • 350
shanematthews
Super solver
722 Views
Message 2 of 12
Flag for a moderator

Re: Can't forward port 27015

Have you also made sure the firewall on the machine running the server is opening those ports, and that you're using a properly configured HLDS instance

0 Kudos
Reply
  • 7
  • 0
  • 0
clubby789
Joining in
716 Views
Message 3 of 12
Flag for a moderator

Re: Can't forward port 27015

I believe the firewall is open, but where would I check? Also, I think the dedicated server instance is configured properly as I can join it through local IP.

0 Kudos
Reply
  • 7
  • 0
  • 0
clubby789
Joining in
710 Views
Message 4 of 12
Flag for a moderator

Re: Can't forward port 27015

Also, using Steam's server API on my server IP got me this:

{
	"response": {
		"success": true,
		"servers": [
			{
				"addr": "[My IP:Port]",
				"gmsindex": 65534,
				"appid": 4000,
				"gamedir": "garrysmod",
				"region": 3,
				"secure": true,
				"lan": false,
				"gameport": 27015,
				"specport": 0
			}
		]
		
	}
}
0 Kudos
Reply
  • 11.37K
  • 405
  • 1K
legacy1
Alessandro Volta
691 Views
Message 5 of 12
Flag for a moderator

Re: Can't forward port 27015

Turn the firewall to low or off for the SH1

but you should think about getting your own router and use modem mode.

0 Kudos
Reply
  • 7
  • 0
  • 0
clubby789
Joining in
680 Views
Message 6 of 12
Flag for a moderator

Re: Can't forward port 27015


@legacy1 wrote:
Turn the firewall to low or off for the SH1


What do you mean by this and how would I do this?

0 Kudos
Reply
  • 11.37K
  • 405
  • 1K
legacy1
Alessandro Volta
677 Views
Message 7 of 12
Flag for a moderator

Re: Can't forward port 27015


@clubby789 wrote:

@legacy1 wrote:
Turn the firewall to low or off for the SH1


What do you mean by this and how would I do this?


The firewall setting in the hub if in router mode.

http://192.168.100.1/advanced_list.asp

 

 

0 Kudos
Reply
  • 7
  • 0
  • 0
clubby789
Joining in
675 Views
Message 8 of 12
Flag for a moderator

Re: Can't forward port 27015

It's already set to low

0 Kudos
Reply
  • 11.37K
  • 405
  • 1K
legacy1
Alessandro Volta
673 Views
Message 9 of 12
Flag for a moderator

Re: Can't forward port 27015

Are you running windows firewall for the server? Check the Advanced Security run WF.msc inbound rules that your server is allowed.

run this to check the port is running.

netstat -a

0 Kudos
Reply
  • 7
  • 0
  • 0
clubby789
Joining in
667 Views
Message 10 of 12
Flag for a moderator

Re: Can't forward port 27015

I added an 'Allow' rule for srcds.exe in firewall, and netstat says the port is listening but I still cannot connect.

0 Kudos
Reply