Menu
Reply
  • 403
  • 18
  • 119
Luke_113
Fibre optic
161 Views
Message 1 of 4
Flag for a moderator

Blizzard.net Domain seemingly blocked by Virgin?

If I use 4G on my mobile I can connect to their services absolutely fine, if via my Virgin connection I cannot reach anything Blizzard related, the launcher doesn't show as online, only in some sort of offline mode, can't see my friends list, nor do any game updates for any Blizzard game....it was working fine until I signed out at about 3:30am this morning (04.02.19). Get in this evening boot up the launcher as I know there's an update for the game (which shows as downloadable but fails) I play alot of. If I open a browser and try and goto Blizzards home page, the page instantly times out with the reason being dns related

Is anyone else experiencing this issue?

I use my modem in modem only mode (I'm on the business service so I have a Hitron CGNv4), I've tried a restart since the modem had an uptime of 57 days but no joy....and of course Virgin's network status page shows no issues.

0 Kudos
Reply
  • 11.53K
  • 413
  • 1.01K
legacy1
Alessandro Volta
158 Views
Message 2 of 4
Flag for a moderator

Re: Blizzard.net Domain seemingly blocked by Virgin?

0 Kudos
Reply
Highlighted
  • 403
  • 18
  • 119
Luke_113
Fibre optic
136 Views
Message 3 of 4
Flag for a moderator

Re: Blizzard.net Domain seemingly blocked by Virgin?

Further looking into it, is showing that its a Liberty Global issue as its affecting alot of european ISPs also owned by Liberty Global. Also as I said in my original post that on my phone via 4G zero issues.

Not that we'd ever get any confirmation from Virgin on the matter though
0 Kudos
Reply
  • 343
  • 33
  • 97
DreamOfCheese
Superfast
123 Views
Message 4 of 4
Flag for a moderator

Re: Blizzard.net Domain seemingly blocked by Virgin?

Considering the issue appears to have been something related to DNS as changing DNS servers to 1.1.1.1 fixed it for people, and it affected people using ISPs ranging from Virgin Media in the UK and ROI (who don't use the same network as each other) to Telefonica in Spain (which isn't a Liberty Global owned ISP), with many more in between I don't think it was an issue with Virgin or Liberty Global.

It also wouldn't load via 4G on EE for me earlier just to add.
0 Kudos
Reply