Menu
Reply
Highlighted
  • 4
  • 0
  • 0
Joining in
356 Views
Message 1 of 10
Flag for a moderator

Bitrate is going down when streaming causing lag

Hello, as of a couple of months my streams have been lagging out of nowhere. I use SLOBS and when I checked it was showing the bit rate occasionally dipping from 2500-3000 to 687 to even 0 and some points and then going back up after a few minutes. 

Now earlier this year I had zero problems, I have not changed any settings, it just one day started to happen and it's getting worse the more I stream. I was told it's a connection stability problem which is either my end or my ISP. I have changed my ethernet cable which is connected to the PC. I stream to twitch and youtube and both individually and problem still persists. I've changed settings and nothing. At this rate I'll have to stop streaming, does anyone have any ideas? thanks.

0 Kudos
Reply
Highlighted
  • 144
  • 36
  • 37
Forum Team
Forum Team
336 Views
Message 2 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Hi,

If you could private message me your account number and site/area reference number I can look into this for you! Be sure not to send them openly on the forum!

Thanks,
Steve
-------------------------------------------------------------------------------------
I am a Virgin Media Field Technician currently working from home. All and any advice given is based on my experience in the field. If my answer was helpful to you please Mark as helpful or consider leaving the post some Kudos.
-------------------------------------------------------------------------------------
Did you know you can get £50 off your bill for referring friends and family to Virgin Media? Want to know more? Just drop me a message!

Here to help! I'm a technician helping out whilst working from home. Find out more


0 Kudos
Reply
Highlighted
  • 4
  • 0
  • 0
Joining in
209 Views
Message 3 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Hi, still have the problem, it's getting worse infact. Here is a screenshot from my last stream. As you can see the bitrate went to 0 and I got disconnected for a few minutes. This happened a few times through out the stream, this is getting frustrating. My internet in general has been acting a lot slower as of this post, pages are taking longer to load, what on earth is going here?. https://ibb.co/1LCZCfd

0 Kudos
Reply
Highlighted
  • 1.48K
  • 55
  • 114
Forum Team
Forum Team
174 Views
Message 4 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Hi GBUKjai,

 

Thank you for getting back in touch. 

 

I am afraid we have not been able to view your screenshot as it isnt available. 

 

Are you able to run a broadband quality monitor on the service and post the results?

You also have the option to log in to your Hub and pull the reports for the connection status, more information on how to do this can be found here: 

https://www.virginmedia.com/help/virgin-media-hub-connection-status

 

Thanks

 

 

Nat
0 Kudos
Reply
Highlighted
  • 4
  • 0
  • 0
Joining in
112 Views
Message 5 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Strange that the image isn't available, works fine for me. it should work now in this post. Here's another speed test: Status from router settings states it's fine. I've just set up a broadband quality monitor with thinkbroadband so I have to wait for some results.

test.png

Here is my log from my Friday's stream from OBS: 

Spoiler
20:17:59.270: ==== Streaming Start ===============================================
21:09:24.808: WriteN, RTMP send error 10054 (484 bytes)
21:09:24.851: WriteN, RTMP send error 10054 (65 bytes)
21:09:24.852: WriteN, RTMP send error 10038 (42 bytes)
21:09:24.852: [rtmp stream: 'adv_stream'] Disconnected from rtmp://amsterdam.restream.io/live
21:09:24.852: Output 'adv_stream': stopping
21:09:24.852: Output 'adv_stream': Total frames output: 90998 (92537 attempted)
21:09:24.852: Output 'adv_stream': Total drawn frames: 92490 (92597 attempted)
21:09:24.852: Output 'adv_stream': Number of lagged frames due to rendering lag/stalls: 107 (0.1%)
21:09:24.853: Output 'adv_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 1539 (1.7%)
21:09:24.854: Output 'adv_stream': Reconnecting in 10 seconds..
21:09:24.855: [rtmp stream: 'adv_stream'] Freeing 808 remaining packets
21:09:24.858: Video stopped, number of skipped frames due to encoding lag: 8/92567 (0.0%)

It's says "number of dropped frames due to insufficient bandwidth/connection stalls"

0 Kudos
Reply
Highlighted
  • 4
  • 0
  • 0
Joining in
134 Views
Message 6 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

I don't think my post went through for some reason. Here is the screenshot that wasn't working: Bit rate 0 on OBSBit rate 0 on OBS
Did another speed test:

 

I created a live broadband quality monitor on ThinkBroadband.

Today's GraphToday's Graph

Also I checked the router settings and it's says it's fine.

This is the log from one of my streams using OBS:

Spoiler
20:17:59.270: ==== Streaming Start ===============================================
21:09:24.808: WriteN, RTMP send error 10054 (484 bytes)
21:09:24.851: WriteN, RTMP send error 10054 (65 bytes)
21:09:24.852: WriteN, RTMP send error 10038 (42 bytes)
21:09:24.852: [rtmp stream: 'adv_stream'] Disconnected from rtmp://amsterdam.restream.io/live
21:09:24.852: Output 'adv_stream': stopping
21:09:24.852: Output 'adv_stream': Total frames output: 90998 (92537 attempted)
21:09:24.852: Output 'adv_stream': Total drawn frames: 92490 (92597 attempted)
21:09:24.852: Output 'adv_stream': Number of lagged frames due to rendering lag/stalls: 107 (0.1%)
21:09:24.853: Output 'adv_stream': Number of dropped frames due to insufficient bandwidth/connection stalls: 1539 (1.7%)
21:09:24.854: Output 'adv_stream': Reconnecting in 10 seconds..
21:09:24.855: [rtmp stream: 'adv_stream'] Freeing 808 remaining packets
21:09:24.858: Video stopped, number of skipped frames due to encoding lag: 8/92567 (0.0%)

I can attach the full log if needed. But it does say "due to insufficient bandwith/connection".

0 Kudos
Reply
Highlighted
  • 471
  • 31
  • 51
Forum Team
Forum Team
93 Views
Message 7 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Hi GBUKjai,

 

Thanks for your post, I'll have a look at your account. I'll send you a PM.

 

Cheers,

Corey C

0 Kudos
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
78 Views
Message 8 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Hello, Did you manage to get to the bottom of this problem around 8pm even though i was fine 3 hours prior,
I am trying to figure out if its congestion or a type of throttling during this pandemic or my super hub?

any help from forum techies would be appreciated aswel
0 Kudos
Reply
Highlighted
  • 28.82K
  • 1.35K
  • 4.96K
Very Insightful Person
Very Insightful Person
72 Views
Message 9 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

its not throttling as vm do not throttle connections. start your own thread and someone can help you

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

0 Kudos
Reply
Highlighted
  • 1.4K
  • 64
  • 98
Forum Team
Forum Team
22 Views
Message 10 of 10
Flag for a moderator

Re: Bitrate is going down when streaming causing lag

Thank you for your post and welcome to our community.

 

I can currently see a fault in your area which may be affecting your connection. This is in relation to the SNR and I'll include the information below.

 

Reference: F008080368 

Estimated fix time: 08 JUN 2020 09:00

 

You may be able to check for updates on our service status page or alternatively you can quote the reference above to any agents for this.

 

Thank you, Emily.

0 Kudos
Reply