Showing results for 
Search instead for 
Did you mean: 

Unable to access manage accounts section on my profile, also some email accounts not working

Tuning in


I am able to login to virgin website fine but every time I try to access the 'manage accounts' section in my profile it keeps saying oops this page is broken etc... I was able to access this yesterday morning but can't anymore.

I want to gain access to this section so as I can update my other email accounts etc. Also I am unable to login to webmail on a few of my other virgin email accounts as it states this mailbox is not available at the moment. I can login with my main account but not some of my other ones.

Please advise


The changes I need to make require me to let a member of Virgin Media staff choose my password for my email accounts.

I cannot change my email password. That is the main problem with this ongoing issue.

This has now been ongoing for 6 months!!

For all your wonderful adverts for the fastest broadband and the best equipment, your IT department are crap!!



I can see on Friday - Beth got back to you to advise she has re-raised the IT ticket, I can only apologise. 


Please keep us posted on what the team advise when they reach out to you. 




Hi Ryan, its been over 6 months now, so I don't expect anyone from the team to reach out to me soon!!

Thanks for coming back to us @aleighen, the team have stated on your notes that they have tried to call you last week, to advise that no issues have been found with your account. Please could you clear your browsers cache and try to access that part of your account again for?



No one called me last week.

Do they have the correct number?

Have now tried again after clearing cache, and I still have the issue.

Tried with Edge, Firefox and Chrome.

If there are no issues with the account, how come Beth logged into my account and found the exact same problem!!

My issue is still ongoing also.

I was going to log in and check if I still can't get access to the link to manage my mailboxes, but today I can't even get that far;

This is the first issue I get when trying to log in;


close the browser tab and try again, and it's OK.

Then I get this;


Tried Chrome and IE - same problem.  Tried lots of different links - keep getting the 'Bad Request' message.

Tried the PlusNet website - no problems, so don't think it's a local machine problem at my end.

I would like to find out about WiFi extension pods - but can't get reliable access to the website to do so!




I've had the same problem for 6 months and it has been verified by at least one member of the forum team by logging into my account. I've also tried different browsers and devices and clearing caches etc but it makes no difference.

I've been assured that the IT people are working on it and it's been escalated which seems hard to believe.

Paul has suggested to me that the best bet would be to delete my online account and set up a new one from scratch but I don't have any confidence that that would work or that the IT team would be able to fix it if it didn't.

It seems like a lot of people have this problem and I wonder if it has anything to do with the fact that I was originally an NTL customer and had an email address.

Just spoken to Virgin customer services again to rest my password.

They confirmed that the problem still exists and have logged it again to IT.

Someone is telling porkies!!

Looking through this and other forums, it seems that a lot of people are having the same issues.

Virgin Media keep fobbing me and others off with the " I have escalated the issue" nonsense.

I have twice made this into an official complaint, and both times Virgin have closed the complaint saying the problem has been fixed.

This is clearly not the case.

I too have been a Virgin customer since the NTL days, so I have an email address also.

Can't see why a dedicated IT team can take over 6 months to sort this out.