Menu
Reply
Highlighted
  • 10.02K
  • 1.1K
  • 4.8K
Very Insightful Person
Very Insightful Person
517 Views
Message 41 of 57
Flag for a moderator

Re: Problem with outlook

Here is Microsoft's explanation of this error:

https://support.microsoft.com/en-gb/help/2483175/sending-mail-from-outlook-results-in-error-0x800ccc...


As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped



0 Kudos
Reply
Highlighted
  • 26
  • 0
  • 7
On our wavelength
513 Views
Message 42 of 57
Flag for a moderator

Re: Problem with outlook

Thanks Howard, I have 4 email accounts on outlook, and 3 of them work, but my main one - the settings are all correct and the logon works and the test message says its sent OK, but nothing comes into my inbox.  Its weird because all the others are OK and all the setting are the same.  

0 Kudos
Reply
Highlighted
  • 10.02K
  • 1.1K
  • 4.8K
Very Insightful Person
Very Insightful Person
507 Views
Message 43 of 57
Flag for a moderator

Re: Problem with outlook

Edit out your public e-mail address please. Public forum, spammers are watching for this.


As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped



0 Kudos
Reply
Highlighted
  • 26
  • 0
  • 7
On our wavelength
503 Views
Message 44 of 57
Flag for a moderator

Re: Problem with outlook

Sorry

0 Kudos
Reply
Highlighted
  • 18.1K
  • 1.01K
  • 7.68K
Very Insightful Person
Very Insightful Person
447 Views
Message 45 of 57
Flag for a moderator

Re: Problem with outlook

@janniz 

Looking at the error message - the page Howard Linked to actually has bad information.  This is not Howard's fault.  I certainly wouldn't expect Microsoft to be wrong here - but they are.

The error message says that your mail client is trying to authenticate with the server - but it can't because the server isn't advertising the methods that the client is using.  Being that Outlook supports a number of authentication mechanisms - this seems surprising.  So I decided to dig into the domain.

Looking at the inbound SMTP servers for your domain.

C:\Users\timdu_000>dig +short mx cablecomb.com
10 mail.cablecomb.com.

You also use this mail server for POP3/IMAP and outgoing SMTP.  The term for such a server is a Smart Host/

Now while I appreciate you say you've been using the same settings for 10 years, that doesn't stop your host changing the server in the background.

However checking the server myself - I do see it supports SSL/TLS and StartTLS connections..  So I would recommend you upgrade your settings.

Your POP3 should be changed in More settings to SSL/TLS encryption - this will change the port number to 995 automatically.

Your SMTP should be changed in More settings to StartTLS encryption - THEN change the port number to 587.

Why make these changes?

When you connect to a mail server on port 110 and 25 unencrypted - your username and password are sent across the internet in plain text.  Meaning anyone who can sniff traffic can grab your account details.  This has been known since before 1995.  Although encryption was studied before then, it was only in 1995 that the US Government was finally convinced that the benefits of encryption to business outweighed potential harms and SSL was implemented by Netscape.

The port change on SMTP is also important.  While I can't say what happened before.  I attempted to connect to the mail server on port 25 and 587

First port 25

C:\Users\timdu_000>telnet mail.cablecomb.com 25

220 mail151.extendcp.co.uk ESMTP Exim Fri, 11 Oct 2019 13:58:04 +0100
ehlo desktop
250-mail151.extendcp.co.uk Hello host31-49-xxx-xxx.range31-49.btcentralplus.com [31.49.xxx.xxx]
250-SIZE 31457280
250-8BITMIME
250-PIPELINING
250-CHUNKING
250 HELP

Now port 587

220 mta2.hi.local ESMTP Exim 4.92.3 Fri, 11 Oct 2019 13:59:56 +0100
ehlo desktop
250-mta2.hi.local Hello host31-49-xxx-xxx.range31-49.btcentralplus.com [31.49.xxx.xxx]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN CRAM-MD5
250-CHUNKING
250-STARTTLS
250 HELP

Notice this line when we connect to port 587

250-AUTH PLAIN LOGIN CRAM-MD5

This is the announcement of the login methods supported by the server.

So why is this missing when you connect on port 25?

While I can't speak for your host as to previous configuration - port 25 is principally used for inbound mail - While it is still allowed for outbound mail in order to support older clients - in reality no one should really be using such clients today.  The principal fault for outbound mail is 587.

However inbound mail servers don't use authentication (in fact they can't)  So the server rightly doesn't advertise any authentication methods.

I would suggest to your host that they still support StartTLS on port 25 - as a number of providers - including Virgin Media - support encryption when sending mail to inbound servers that support it (my own mail server supports this).

Because the server is not sending any authentication methods when Outlook connects on port 25, Outlook throws the error you reported.

Tim

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

Highlighted
  • 26
  • 0
  • 7
On our wavelength
441 Views
Message 46 of 57
Flag for a moderator

Re: Problem with outlook

Hi Tim

You are a godsend.  The port numbers you gave me don't work - it only works with 110 and 25.  However, the error is still there and therefore we can now receive and not send emails.  I have copied what you last said and sent it to our guy, so hopefully he will talk to them and sort it out.  Also maybe you could shed some light as to why when my emails come in, I can't see them.  Someone suggested I delete the account and start again, I did this once and it worked, but again I can see emails coming in on the pop up thing on the right hand side, but they're nowhere in my outlook.

 

Thanks

 

Highlighted
  • 18.1K
  • 1.01K
  • 7.68K
Very Insightful Person
Very Insightful Person
429 Views
Message 47 of 57
Flag for a moderator

Re: Problem with outlook

Can you confirm the two mail servers are mail.cablecomb.com and mail.csi.co.uk

Here's me attempting a StartTLS connection on Port 587

C:\Users\timdu_000>openssl s_client -connect mail.cablecomb.com:587 -starttls smtp -quiet
depth=1 C = BE, O = GlobalSign nv-sa, CN = GlobalSign Domain Validation CA - SHA256 - G2
250 HELP
ehlo desktop
250-mta2.hi.local Hello host31-49-xxx.xxx.range31-49.btcentralplus.com [31.49.xxx.xxx]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN CRAM-MD5
250-CHUNKING
250 HELP
quit
221 mta2.hi.local closing connection

Now lets try a POP3 conection to port 995

C:\Users\timdu_000>openssl s_client -connect mail.cablecomb.com:995 -quiet
depth=1 C = BE, O = GlobalSign nv-sa, CN = GlobalSign Domain Validation CA - SHA256 - G2
+OK Dovecot ready. <5d46.e402a.5da0864f.WHgz/RW4JIkzBKj8RSIwHQ==@mail151.extendcp.co.uk>
quit
+OK Logging out

Works OK here - Did you change the port numbers only?  YOU MUST CHANGE THE ENCRYPTION TYPE

Lets do the same for mail.csi.co.uk

C:\Users\timdu_000>openssl s_client -connect mail.csi.co.uk:587 -starttls smtp -quiet
depth=1 C = BE, O = GlobalSign nv-sa, CN = GlobalSign Domain Validation CA - SHA256 - G2
250 HELP
ehlo desktop
250-mta3.hi.local Hello host31-49-xxx-xxx.range31-49.btcentralplus.com [31.49.xxx.xxx]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN CRAM-MD5
250-CHUNKING
250 HELP
quit
221 mta3.hi.local closing connection
C:\Users\timdu_000>openssl s_client -connect mail.csi.co.uk:995 -quiet
depth=1 C = BE, O = GlobalSign nv-sa, CN = GlobalSign Domain Validation CA - SHA256 - G2
+OK Dovecot ready. <15e1d.2fa8b6.5da08748.zUHNS9ktFwjKuQWr900QvA==@mail114.extendcp.co.uk>

 

If this works for me - it will work for you.  You should be aware by now that I do not indulge in guesswork when giving advice.

Tim

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

Highlighted
  • 26
  • 0
  • 7
On our wavelength
341 Views
Message 48 of 57
Flag for a moderator

Re: Problem with outlook

Hi Tim

New problem - We are now getting a error message of 550 when the emails we send are bouncing back -  Server error: '550 relay not permitted',  I looked this up and it said that it could only be 1 of 3 options.  The emails address is incorrect 9 (No) the settings are wrong (no) or there is a ISP blockage.  This is most likely don't you think given our history?

Janet

 

0 Kudos
Reply
Highlighted
  • 18.1K
  • 1.01K
  • 7.68K
Very Insightful Person
Very Insightful Person
315 Views
Message 49 of 57
Flag for a moderator

Re: Problem with outlook

No I don't think it likely at all.

What you are seeing is what I'd expect from a properly configured Smarthost when someone tries to send mail on port 25.

Let me demonstrate using my own Smart Host using real email addresses.

First Port 25 StartTLS

250 SMTPUTF8
ehlo desktop
250-box.timothydutton.co.uk
250-PIPELINING
250-SIZE 134217728
250-VRFY
250-ETRN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 SMTPUTF8
auth plain
503 5.5.1 Error: authentication not enabled
mail from: <sender@timothydutton.co.uk>
250 2.1.0 Ok
rcpt to: <recipient@blueyonder.co.uk>
554 5.7.1 Service unavailable; Client host [86.128.xxx.xxx] blocked using zen.spamhaus.org; <a href="https://www.spamhaus.org/query/ip/86.128.xxx.xxx" target="_blank">https://www.spamhaus.org/query/ip/86.128.xxx.xxx</a>
quit
221 2.0.0 Bye
closed

Note I've masked the email addresses but they were genuine addresses originally.

Now we see two things here.

1.  There are no authentication methods listed in the greeting.  Indeed I tried going for AUTH PLAIN but this was rejected.
2.  The send was blocked as my current IP address is listed on Spamhaus' PBL - hand hence Zen as well.

So why?

Well the Smart host looks at the traffic the port is coming in on - port 25 and thinks "this is for inbound mail!"  So it can't use authentication to protect itself, so it uses other means.

Now on this port there's another important consideration.  Making sure that the server does not act as an open relay.

Thus when the connection is made on port 25 the ONLY domains allowed in the RCPT TO: command are domains which the server explicitly looks after anyway.

If it allowed connection to other domains then it would be what spammers love - an open relay.

Hence you get the relaying denied error.

Now lets try my server again this time on port 587

250 SMTPUTF8
ehlo desktop
250-box.timothydutton.co.uk
250-PIPELINING
250-SIZE 134217728
250-VRFY
250-ETRN
250-AUTH PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 SMTPUTF8
auth plain
334
<redacted>
235 2.7.0 Authentication successful
mail from: <sender@timothydutton.co.uk>
250 2.1.0 Ok
rcpt to: <recipient.dutton@blueyonder.co.uk>
250 2.1.5 Ok
rset
250 2.0.0 Ok
quit
221 2.0.0 Bye
closed

This time the recipient address is accepted.  Again why?

Well when the server sees the connection come in on port 587 it thinks "This is outbound mail"

Therefore we see the authentication methods AUTH PLAIN and LOGIN advertised in the capabilities.

Checking of Spamhaus does not take place because this is evidently a mail client such as outlook sending email onwards rather than a MTA delivering mail.

I sent Auth Plain and then I sent my username and password which the server accepted.  Had I not sent the user info - I'd have got a warning telling me to authenticate first.

Finally we see that the RCPT: to message was accepted in this case.  Had I wanted to I could have gone on and delivered an email.

Tim

TL:DR Version

Talk with your host and double check your ports, because based on what I'm seeing you're your own worst enemy here.  You're sticking to the blind assumption that it's all Virgin Media's fault when in fact it's nothing to do with them.

I will reiterate.

Pop 3 port is 995
Encryption type MUST be SSL/TLS (SSL in Outlook 2013 and older)

SMTP port is 587
Encryption type MUST be StartTLS (TLS in Outlook 2013 and older)

In More Settings -> Outgoing Tab

Enable - My Outgoing Server requires authentication

Enable - Use same settings as incoming server.

Tim

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

0 Kudos
Reply
Highlighted
  • 26
  • 0
  • 7
On our wavelength
310 Views
Message 50 of 57
Flag for a moderator

Re: Problem with outlook

Thank you Tim for your explanation.  I am not blaming Virgin anymore.  I changed my colleagues settings to those you stated, and it logs on OK and sends test message, but when he sends an email to anyone else, it still bounces back with that 550 error.  We can send emails internally and it works fine.  However, my settings are on the old port numbers as your ones don't work, and I now get the same error.  

0 Kudos
Reply