Menu
Reply
PRL
  • 10
  • 0
  • 2
Tuning in
250 Views
Message 1 of 4
Flag for a moderator

How do I stop all email going into the spam folder.

All  emails sent to me are going into my virgin.net spam folder despite filter setting mark as spam and deliver to inbox in settings ticked . It does not matter what you do with the filters ie turn on or off all my emails are going into the spam folder even if I send my self a test email or virgin send me an email

Kind regards 

0 Kudos
Reply
用心棒
  • 5.66K
  • 634
  • 1.97K
Very Insightful Person
Very Insightful Person
234 Views
Message 2 of 4
Flag for a moderator
Helpful Answer

Re: How do I stop all email going into the spam folder.

Restore default Spam Settings by selecting ☰ > Settings > Email > SPAM Settings > Move message to Spam folder

If you send yourself a message with the Subject test and message message, does it arrive in your Inbox or Spam folder? If the latter can you just post its X-Spam, X-Spam-Action, X-Spam-Reason lines here.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more
Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

PRL
  • 10
  • 0
  • 2
Tuning in
137 Views
Message 3 of 4
Flag for a moderator

Re: How do I stop all email going into the spam folder.

Thank you for your reply and help, for information this is what I have done :-

(1) Checked the Spam Setting :-the “Flag a message as Spam but deliver to Inbox” was ON.

(2) Test emails were sent to my virgin.net email account , these all went into the Spam Folder.

(3) On the received emails selected the “View Source” and searched for “X-Spam, X-Spam-Action and X-Spam-Reason ” But none of these were found

(4) Changed Spam setting back to default as suggested, toMove Message To Spamand then sent test emails again, these did not go into the inbox but all went into the Spam Folder.

(5) Selected the “View Source” and searched for “X-Spam, X-Spam-Action and X-Spam-Reason But none of these were found.

Problem solved below ??:-

(6) Keeping the default as suggested, to Move Message To Spam”.

(7) On Settings , Email Filter Rules , Except for the Blacklist filter , I turned off / disabled all of the individual e-mail filters I had created to manage spam emails received etc.

(8) Sent test emails , these all went into the inbox ie this solved the problem , so there may be a conflict caused by the filters, I am happy to live with this and have not tried turning filters back on one at a time and re testing.

Blacklist

As the individual filter rules are turned turned off / disabled I am relying on Blacklisting to try to stop spam not picked up by Virgin and have found there is approximate 250 limit you can add to this.

Kind Regards PRL

0 Kudos
Reply
用心棒
  • 5.66K
  • 634
  • 1.97K
Very Insightful Person
Very Insightful Person
130 Views
Message 4 of 4
Flag for a moderator
Helpful Answer

Re: How do I stop all email going into the spam folder.

Good to read you have isolated the cause. If any of your filer rule's Conditions use Regex then check their alternations (which acts like a boolean OR) are valid. For example a From address of Richard Branson <richard.branson@virginmedia.com> with a Regex pattern of:

  • pattern-0|pattern-1| |pattern-N would be matched because of the space character alternation (shown in red)
  • pattern-0|pattern-1||pattern-N would be matched because of the empty alternation (again, shown in red); @ModTeam, this is a bug that result in any value being matched.