Menu

All Unanswered Topics

Subject Author Date/time
Today I had my long awaited install. The guys installed everything but the router is stuck in creati...
7 minutes ago
Hi there Over the last week our superhub has been playing up and keeps dropping out. After resetti...
11 minutes ago
My connection keeps dropping every so often (about once an hour) I have recently bought a new netwo...
11 minutes ago
Hi - been getting really bad download speeds over the last few days (2-3Mbps) and when contacting th...
an hour ago
I keep losing wi-fi signal and having to switch hub off 2-3 times a day to get it back.
2 hours ago
My wifi is extremely slow (considering I am supposed to have 50mb) and it will not stop disconnectin...
3 hours ago
Received a text from virgin telling me ive received my order when i havent received anything.What do...
4 hours ago
This totally unacceptable: 2017-12-13 12:21:28.00 84000700 RCS Partial Service;CM-MAC=**:**:*...
5 hours ago
My router was upgraded to hub 3.0. My original problem is still not resolved which was with your ...
6 hours ago
I was sure I posted a couple of days back but it's not there, so adding again. Same issue with my ...
6 hours ago
I have raised an issue many times with regards to my broadband speeds being unreliable and at times...
7 hours ago
I keep losing broadband. NOT JUST WIFI. I have tried contacting virgin and get no help just excuses....
7 hours ago
Like many others it seems VM servers are getting blacklisted quite regularly, there doesn't seem any...
7 hours ago
Been flaky since last night. Yet somehow amazingly the Status page shows as no issues. Come on Virgi...
11 hours ago
Hello, I am experiencing a problem where my broadband connection drops in the middle of the day, a...
yesterday
HI, i recently moved in to W14 from old place. I always have virgin media and use to love it. B...
yesterday
Over the past week my wifi signals have been constanly dropping on the superhub, and popping back in...
yesterday
I keep losing a connection, ping speed is extremely poor, have had to log in a couple of times and ...
yesterday
I regularly do a speedtest and my speed has changed from a fairly regular 40 plus Mbps to less than...
yesterday
Hi. I have recently upgrad to the Hub 3.0 and am trying to configure it so i can restrict the time...
yesterday