Menu
Reply
  • 1
  • 0
  • 0
rallibon
Joining in
98 Views
Message 1 of 2
Flag for a moderator

White noise sound on HD channels

I have a Cisco Virgin HD box that is connected via HDMI to a Sanyo TV and the sound also via Optical cable to external speakers and a subwoofer. I am using a Sonos Zoneplayer 120 as an amp to power Onkyo speakers using an Optical to RCA converter.  This works fine for all non-HD TV channels (and also separately using a DVD player) but whenever I turn on a Virgin HD TV channel the sound is replaced by horrible distorted "white noise".  Can anyone tell me how this can be resolved?  For example Sky Sports 1 works fine but Sky Sports 1 HD has the terrible distortion.

Many thanks in advance.

0 Kudos
Reply
  • 20.24K
  • 733
  • 1.51K
Forum Team
Forum Team
78 Views
Message 2 of 2
Flag for a moderator

Re: White noise sound on HD channels

Hi rallibon, 

 

Thanks for your post and welcome to the Community. 

 

Apologies to hear about the issues you are having trying to view the HD channels. 

 

What is the sound like on these channels when you remove the equipment and use only the TV Sound? Does this still give the same horrid noise or does the sound play correctly? 

 

Rather than connecting via the optical cable, do you have the option to connect up via HDMI? If so give this a try to see if there is a difference. 

 

Finally double check the sound settings you have selected. It may be worth trying to alter these slightly to see if there is any difference. 

 

Come back and let me know how you get on. 

 

Thanks,

Kath_F
Forum Team

Tech fan? Have you read our Digital life blog yet? Check it out



0 Kudos
Reply