Menu
Reply
  • 3
  • 0
  • 0
Grahams-Boy1
Joining in
2,640 Views
Message 1 of 6
Flag for a moderator

TiVo stuck 25% preparing channels

Hi.
My TVs was playing away fine all day but suddenly stated the channel I was watching wasn't working or something.
It's now stuck on "preparing channel information" at 25% for over an hour.
My father in law is having the same problem.
Any help is appreciated.
0 Kudos

Helpful Answers
  • 133
  • 4
  • 21
Flipshot
Up to speed
5,254 Views
Message 2 of 6
Flag for a moderator
Helpful Answer

Re: TiVo stuck 25% preparing channels

There is a large outage on TV at the moment that seems to be affecting at least most of Hertfordshire and Bedfordshire. Mine is stuck on 25% too at the moment. Service status page is now saying it will be fixed by 8.10pm.

0 Kudos

All Replies
  • 133
  • 4
  • 21
Flipshot
Up to speed
5,255 Views
Message 2 of 6
Flag for a moderator
Helpful Answer

Re: TiVo stuck 25% preparing channels

There is a large outage on TV at the moment that seems to be affecting at least most of Hertfordshire and Bedfordshire. Mine is stuck on 25% too at the moment. Service status page is now saying it will be fixed by 8.10pm.

0 Kudos
  • 3
  • 0
  • 0
Grahams-Boy1
Joining in
2,622 Views
Message 3 of 6
Flag for a moderator

Re: TiVo stuck 25% preparing channels

Thanks for the info
0 Kudos
  • 1
  • 0
  • 0
Rmckinley
Just joined
2,601 Views
Message 4 of 6
Flag for a moderator

Re: TiVo stuck 25% preparing channels

Mine won't get passed 'starting up'! Just been on hold for 30mins to be told estimated sort time will be 8:55pm this evening. Only been with Virgin for a few weeks. So disappointed so far....

0 Kudos
  • 46
  • 0
  • 0
mtiller
Tuning in
2,591 Views
Message 5 of 6
Flag for a moderator

Re: TiVo stuck 25% preparing channels

Hi,

Stopping at "Starting up" may be a different error.

To fix,

1. Disconnect HDMI cable from Virgin Box (it runs to the TV).
2. Pull power cable out of the Virgin box.
3. Wait 10 secs and plug power cable back in.
4. Hit power button on Virgin box
5. Wait 10 minutes and plug the HDMI cable back into the VM box.

This process worked for me last week. Hope it helps, of course right now it may not make any difference!

Mark

0 Kudos
  • 7.24K
  • 281
  • 547
Forum Team
Forum Team
2,524 Views
Message 6 of 6
Flag for a moderator

Re: TiVo stuck 25% preparing channels

Hi Grahams-Boy1,

A warm welcome to our community Smiley Happy

I'm sorry to hear that you experienced this disruption. I just wanted to pop by and see how things are today?

If you're still having any troubles with the service, let me know and I can help further.

Collette Smiley Happy

 


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos