Menu
Reply
  • 1
  • 0
  • 0
hbaxter
Joining in
68 Views
Message 1 of 2
Flag for a moderator

SmartCall incorrect talk plan

I've just installed SmartCall and the settings show my home talk plan as Talk Weekends but I have Unlimited.  Please could you look into this.  We fly tomorrow morning, Mon 08/02/16 and I'd like to get it sorted before we go.

Tags (1)
0 Kudos

Helpful Answers
  • 7.35K
  • 304
  • 650
Moderator
Moderator
54 Views
Message 2 of 2
Flag for a moderator
Helpful Answer

Re: SmartCall incorrect talk plan

Hi there hbaxter, 

I'm really sorry to hear that you've been experiencing issues with Smart Call, I've taken a look into this and have corrected things from our end. 

You should now have the correct plan showing. 

I hope you  enjoy your time away, I can understand your eagerness to get this sorted, as Smart Call has saved me loads over the years whilst I was abroad Smiley Happy

Take care.

Huw


The do's and don'ts. Keep the community welcoming for all. Follow the house rules



All Replies
  • 7.35K
  • 304
  • 650
Moderator
Moderator
55 Views
Message 2 of 2
Flag for a moderator
Helpful Answer

Re: SmartCall incorrect talk plan

Hi there hbaxter, 

I'm really sorry to hear that you've been experiencing issues with Smart Call, I've taken a look into this and have corrected things from our end. 

You should now have the correct plan showing. 

I hope you  enjoy your time away, I can understand your eagerness to get this sorted, as Smart Call has saved me loads over the years whilst I was abroad Smiley Happy

Take care.

Huw


The do's and don'ts. Keep the community welcoming for all. Follow the house rules