Menu
Reply
  • 885
  • 35
  • 476
HughJarsse
Well-informed
788 Views
Message 1 of 35
Flag for a moderator

'oops, somethings gone wrong' AGAIN!!!

OK, been trying to change the tariff on my pay monthly SIM...

Logged in, chose account, chose appropriate phone, click 'my plan', click 'change tariff' chose tariff required, click 'confirm' ,   up pops the dreaded 'oops somethings gone wrong, please try again later' 

left it until the following day, tried again, same again!! tried the following day, same again...

 

OK, tried to choose  a different tariff.....same problem when 'confirm' clicked, goes away, comes back with 'oops' 

This has now happened for a WEEK!!, tried every day, tried 3 different tariffs....

 

WHY offer the option online through 'my account' IF IT DOESN'T WORK????

 

Why should I be FORCED to phone, and wait in an endless loop until being cut off, just to change a tariff?? The last time I did this, it took 3 phone calls, lasting a total of 60 minutes!!!

 

Surely, the 30 seconds spent doing it online is easier, quicker, less stressfull...BUT....

 

This is VM we are talking about!!!  Do you WANT the business or don't you?? IF the online system doesn't work   REMOVE IT!!!

 

I would rather swap phone providers than go through the hassle, stress and frustration of trying to get through on the phone, THEN trying to make someone understand what I want rather than what they want to sell me. (PS this was the UK service as well, NOT overseas!!)

 

Sort it out Virgin, or another customer goes over to the competition!! Smiley Mad

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
725 Views
Message 2 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

HI HughJarsse,

 

Thanks for posting.

 

I'm really sorry that you're having issues changing the tariff over on your online account. I want to look into this for you. Are you able to PM me your full name, mobile number and 3 characters of your password so I can do this?


Let me know as soon as you can.


Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 885
  • 35
  • 476
HughJarsse
Well-informed
716 Views
Message 3 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

PM'd you the info you requested Mat_H 

 

hope this helps sort this out... Smiley Happy

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
714 Views
Message 4 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

Thanks for sending that over HughJarsse Smiley Happy

 

I'll be in touch as soon as possible.

 

I'll do my best to get this sorted.


Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 38
  • 0
  • 3
vvw25w
On our wavelength
698 Views
Message 5 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

Same problem here

0 Kudos
  • 885
  • 35
  • 476
HughJarsse
Well-informed
659 Views
Message 6 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

Mat_H

There are now several other posts regarding this....any news, or are we still waiting for this to be passed on to someone..

If there is nothing sorted by my next refresh date, then VM will get a 30 day notice to terminate the contract, and I will take my custom elsewhere....

Once again, appalling service from VM...this is becoming the norm rather than the exception, sdaly..

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
612 Views
Message 7 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

Hi HughJarsse,

 

I have no news on this particular issue currently. I'll request an update on my side to see if we have any new info.


Thanks for your continued patience while we look into this Smiley Happy


Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 885
  • 35
  • 476
HughJarsse
Well-informed
604 Views
Message 8 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!


Mat_H wrote:

Hi HughJarsse,

 

I have no news on this particular issue currently. I'll request an update on my side to see if we have any new info.


Thanks for your continued patience while we look into this Smiley Happy


Mat


Hi Mat_H

Thanks for the reply, basically what I assumed, sadly.

2 weeks have gone by since I first posted, refresh date is now just over 2 weeks away, so the clock is ticking..

This is not an isolated problem, as there are other posts on the same thing. VM really need to get smart, and address these problems quicker, rather than the current 'yeah, ok, sometime we may look at it' attitude. Perhaps VM think if they don't bother to sort it, people will just let it go. Smiley Sad

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
566 Views
Message 9 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!

Hi HughJarsse,

 

I can promise you that we don't think people will let issues go. I can understand your frustration and we always want to get everything sorted for you as soon as possible.

 

Let me know if you need anything at all.


Thanks,

Mat
 


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 885
  • 35
  • 476
HughJarsse
Well-informed
558 Views
Message 10 of 35
Flag for a moderator

Re: 'oops, somethings gone wrong' AGAIN!!!


Mat_H wrote:

Hi HughJarsse,

 

I can promise you that we don't think people will let issues go. I can understand your frustration and we always want to get everything sorted for you as soon as possible.

 

Let me know if you need anything at all.


Thanks,

Mat
 


Sadly Mat, 

I don't really have any confidence in VM any more...just how long does it take to pass details of a problem that in not only affecting me, but MANY others on the site to the correct department, who, basically, looking at the size of the problem, should be looking to FIX IT rather than repeated lame excuses...

All I want to do is change mobile tariff, as the website is SUPPOSED to do?? not exactly rocket science...you offer the option, either fix it or remove it from the site!!

 

As I said, the clock is ticking, just 2 weeks to refresh, if not sorted, then ALL 4 PHONES  I have with VM will be terminated, and an alternative provider found that is able to provide a DECENT service to it's long serving customers..(AND, also provides 4G, which 2 of our phones are able to do, yet VM won't provide!)

 

Have already had a YEAR of 'high utilisation' with 'reviews' put further and further back, (getting 5meg on a 50meg package!) so this may just be the final straw...

If VM can't/won't get their finger out, then bye bye Virgin, and I'll take £150 worth of business elsewhere...

0 Kudos