Menu
Reply
  • 401
  • 2
  • 4
Beemer
Up to speed
3,642 Views
Message 1 of 14
Flag for a moderator

how to stop sms messages being changed to mms?

How can I stop a Samsung Galaxy s5 changing sms to mms?   This happens shortly after exceeding 120 characters.

Tags (1)
0 Kudos
  • 1.58K
  • 101
  • 270
Superuser
Superuser
3,635 Views
Message 2 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

From the message list, select the bottom-left menu and choose settings. About a third of the way down, change "Input mode" from Unicode to one of the others (automatic or GSM Alphabet).

 

Alternatively, replace the stock text messaging app with a replacement like BigSMS from the Play Store.

0 Kudos
  • 69
  • 4
  • 8
rodbrown1949
Dialled in
3,613 Views
Message 3 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

I have an LG Spirit h440n. The only setting tag I see in Messaging, is at the top and it does not show a category for changing to SMS or anything else. I am using a package simply called Messaging! Any other ideas? If not I have another package called Messenger that I could probably use instead! Thanks

0 Kudos
  • 10
  • 1
  • 2
fbaggy
Tuning in
3,596 Views
Message 4 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

Similar issue on my daughters samsung, you need to go into the message settings and change it to use the GSM alphabet, that should stop it switching to MMS which is what you are getting charged for.

0 Kudos
  • 1.58K
  • 101
  • 270
Superuser
Superuser
3,586 Views
Message 5 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?


fbaggy wrote:

Similar issue on my daughters samsung, you need to go into the message settings and change it to use the GSM alphabet, that should stop it switching to MMS which is what you are getting charged for.


It doesn't stop messages being converted to MMS - it just (more than) doubles the amount you can type before conversion. A single Unicode SMS is 70chars whereas a single GSM SMS is 160chars.

 

 

0 Kudos
  • 69
  • 4
  • 8
rodbrown1949
Dialled in
3,569 Views
Message 6 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

When I go into Messaging and select Settings, it shows me a drop down panel with Notifications, Storage, Text Message, Multimedia message and Quick message. I selected Text message and the options were Delivery reports, Validity period, Service centre address / phone no, Character encoding. I chose Character encoding, and it showed me only Auto or Default alphabet. I was already set for Default alphabet, so I changed it to Auto. Do you think this will help stop the MMS messages?

0 Kudos
  • 1.58K
  • 101
  • 270
Superuser
Superuser
3,564 Views
Message 7 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?


rodbrown1949 wrote:

...I changed it to Auto. Do you think this will help stop the MMS messages?


Not in itself.

 

There are four reasons that your message gets converted to MMS

  • It's too long
  • It's sent to loads of people
  • You attach a file (photo, video, vcard etc)
  • You include an icon which is not part of the extended set

Changing the alphabet helps with the first one, but it doesn't remove the chance of a conversion.

 

When you write a long message, it's chopped down into individual SMS messages and these are recombined into the long message by the recipient's phone. If your message is really long, it gets converted to MMS and sent as a single, chargeable message. The number of SMS messages that need to be "filled" before the phone thinks 'sod it' and creates a MMS depends on the handset, but it may be as few as three combined SMS messages.

 

If you use the standard GSM alphabet, a single SMS message is 160 characters. If you use the Unicode alphabet, it's down to 70 characters. (The unicode alphabet has many more accented and special characters available to it, including the extended icons.)

 

Basically, if you use the GSM alphabet, you get more than twice as many characters before your message is converted to MMS.

 

Depending on your handset, you get a warning when a text message is so long that it converts to MMS. If this happens, you should really be asking yourself: "Should I just ring this person instead?"

  • 69
  • 4
  • 8
rodbrown1949
Dialled in
3,551 Views
Message 8 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

The changes I have made did not resolve the problem as my android phone is still sending MMS! I do not get the options you mention in the settings on the LG Spirit h440n! (see above for the options available to  me)! My messages are very short (2/3 short sentences at most) and I have added no icons or attachments!

With your experience, can you provide more help?

 

0 Kudos
  • 1.58K
  • 101
  • 270
Superuser
Superuser
3,543 Views
Message 9 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

I don't have any experience of the LG, sorry.

 

Does it convert to MMS is you just send one word "Hello" to one recipient?

0 Kudos
  • 1.58K
  • 101
  • 270
Superuser
Superuser
3,541 Views
Message 10 of 14
Flag for a moderator

Re: how to stop sms messages being changed to mms?

Try going into "Messaging" "Settings" "Multimedia messaging" "Creation mode" and change it to "Restricted"

0 Kudos