Menu
Reply
  • 368
  • 11
  • 17
Forum Team
Forum Team
203 Views
Message 11 of 16
Flag for a moderator

Re: Sony Xperia XA will not connect to Virgin wifi

Hi Lavenderpurple

 

Thanks for your reply - I've taken a look at the ticket for your phone.

I've spoke with my manager who is an expert in the mobile world, he's advised that the memory issues could be causing this.

 

What he's advised is to;

 

Factory reset the handset

Don't reinstall your Google profile

Run device for 72hrs without downloading the profile or an additional apps.

If no problem, download Google profile. But for 24hrs don't download an further apps.

 

If no issues then every 24hrs install a new app until all have installed or until an issue crops up.

In which cause this will help us identify what is causing the issue.

 

It's also best to keep an eye on your memory as the more you have on the device this will cause the handset to run slow/crash while running applications. Which in turn could be why the handset is turning the WiFi off.

 

Let us know if you need us further

 

Thanks,

Daniel_G - Forum Team

Need help swapping your SIM card? Find out more about activating your 4G ready SIM here. 4G SIM Swap Help


0 Kudos
Reply
  • 3
  • 1
  • 0
tabber
Tuning in
187 Views
Message 12 of 16
Flag for a moderator

Re: Sony Xperia XA will not connect to Virgin wifi

I ended up here, as have exactly the same issue with a Sony Xperia XA phone, and disconnecting from wifi.

Here is some extra info from my setup. I have a separate Linksys router connected via the back of the Virgin Hub, through some CAT6 cabling in the house, broadcasting on a separate SSID. The location of this router gives whole house coverage, as opposed to the Virgin Hub wifi which is very weak in half the house. Our broadband drops out several times a day for some reason, which causes all devices to temporarily disconnect. This happens regardless of whether you are connected to the linksys (2.5GHz only), or the virgin hub on 2.5 or 5GHz, so I think it must be the incoming connection. 

Got the Xperia XA for my sons birthday a month or so ago through iD mobile, and as soon as our broadband had its first blip, all devices reconnected, except for the Xperia. Nothing will let it reconnect, restart, forget network, wifi off/on toggle, etc. The only thing that works is restarting the router. Somewhat bizarrely, the 5G network is ok. But the same issues happens on Virgin's own 2.5GHz router, and the linksys. The fact it happens on two routers, and other phones and devices all reconnect, makes me think its definitely a fault with the phone.

Also interesting... we have 2 Sony Smart TVs in the house, and both of them occasionally have wifi issues too. Coincidence?

Have logged a support call with Sony about the phone, who have suggested some things to try. Sony Xperia care is 03705237237, if you havent tried that route yet.

I can't see how this is an issue with the wifi through the Virgin Hub, since I have a separate router. Although, that is being fed through the LAN output via cable, so there could be an issue within the Hub that affects both wifi, and LAN connection I suppose.

Hope this helps anyone else who ends up on this thread with the same issue.

 

0 Kudos
Reply
  • 12
  • 0
  • 0
Lavenderpurple
Joining in
158 Views
Message 13 of 16
Flag for a moderator

Re: Sony Xperia XA will not connect to Virgin wifi

Thank you Daniel, but I'm afraid I have already tried the factory reset with no google account after seeing the tip online. Sadly, it made no difference.

Tabber, that's really interesting. Sounds like exactly the same problem!! Would you mind telling me what Sony suggested please? Did it sound like a faulty handset, or something that could be fixed? Thank you.
0 Kudos
Reply
  • 7.9K
  • 246
  • 546
Forum Team
Forum Team
132 Views
Message 14 of 16
Flag for a moderator

Re: Sony Xperia XA will not connect to Virgin wifi

HI Lavenderpurple,

I'm sorry that Daniel's suggestions haven't worked. Has this been resolved for you since your post?

If you are still having an issue with this, please send me a private message by clicking this link: PM me here and provide the following details:

  • Full name on the account
  • Mobile number

Kind Regards,

Terri

Virgin Media Forum Team


Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos
Reply
Highlighted
  • 1
  • 0
  • 0
Linda17
Just joined
25 Views
Message 15 of 16
Flag for a moderator

Re: Sony Xperia XA will not connect to Virgin wifi

I have this exact same problem. I have an Xperia X1 and Virgin Media at home, the only difference is I have a Virgin Media Hub3. My phone connected reliably to our home wi-fi until about 10/11 months ago then suddenly started to lose wifi connection at home. It connects, then disconnects and loops round again. If I restart the phone it works fine for about 10 minutes then disconnects again. A long shot but - this issue seems to have started at around the same time as Virgin made my wi-fi a hotspot and I am wondering if this is related. My phone struggles to connect to Virgin wi-fi on the tube as well. I frequently get the same message both at home and out when trying to connect to Virgin wi-fi "Authentication Problem".
Virgin/Sony - any ideas?
0 Kudos
Reply
  • 368
  • 11
  • 17
Forum Team
Forum Team
3 Views
Message 16 of 16
Flag for a moderator

Re: Sony Xperia XA will not connect to Virgin wifi

Hi linda17

 

Thanks for your post and welcome to our community forums.

I'm sorry about the issues you've had.

Making the Hub a hotspot wouldn't have caused these issues.

 

I'm sorry about the current fault - Have you tried removing the network from the handset and readding it?

 

Thanks,

Daniel_G - Forum Team

Need help swapping your SIM card? Find out more about activating your 4G ready SIM here. 4G SIM Swap Help


0 Kudos
Reply