Menu
Reply
  • 11
  • 0
  • 1
Ian_
Tuning in
177 Views
Message 1 of 5
Flag for a moderator

SmartCall wrong setting

The SmartCall setting on my Galaxy S3 shows 'Talk Weekends' when my plan is 'Talk Unlimited'.  This stops me using SmartCall during weekdays.  Anyone know how to fix this.

Thanks.

0 Kudos

Helpful Answers
  • 2.18K
  • 242
  • 567
teabag
Problem sorter
280 Views
Message 5 of 5
Flag for a moderator
Helpful Answer

Re: SmartCall wrong setting


Ian_ wrote:

The SmartCall setting on my Galaxy S3 shows 'Talk Weekends' when my plan is 'Talk Unlimited'.  This stops me using SmartCall during weekdays.  Anyone know how to fix this.

Thanks.


Best advice would be to pop this question over into the landline phone section, usually gets seen quicker by staff.

It's a problem which has risen quite a lot lately, usally down to a wrong setting somewhere which staff can easily rectify for you. :-)

---------------------------------------------------------------
BB 200 - Hub 3, Phone Talk w/ends, Mobile Sim only £9 and £5 big bundle sim. Customer since 1993.
0 Kudos

All Replies
  • 2.26K
  • 30
  • 199
jhuk
Knows their stuff
167 Views
Message 2 of 5
Flag for a moderator

Re: SmartCall wrong setting

Mines shows the same, not sure if simply a glitch of will effect calls cost.

 

Just checked om My VM site APP's and its showing proper Talk Unlimited.

0 Kudos
  • 11
  • 0
  • 1
Ian_
Tuning in
159 Views
Message 3 of 5
Flag for a moderator

Re: SmartCall wrong setting

Hi jhuk,

It's not that it will affect call costs, it's that I can't make calls using SmartCall, as it gives me the message
'This isn't a SmartCall' and 'This call isn't included in you talk plan.  Do you want to make a normal call from your mobile?''

My VM App page also tells me, correctly, that I have 'Talk Unlimited', though SmartCall settings say 'Talk Weekends'.

0 Kudos
  • 2.26K
  • 30
  • 199
jhuk
Knows their stuff
152 Views
Message 4 of 5
Flag for a moderator

Re: SmartCall wrong setting

Ah bummer, I have not used my phone to make a call lately as signal is poor since May 2015.

I know Smartcall is to help with this but if I am home I just use my landline for the very few calls I make.

 Use my mobile on wifi for listening to music with earphones in when I want peace etc.

The time I tested Smartcall the call the sound quality was different from over the mobile network, poorer IMO.

0 Kudos
  • 2.18K
  • 242
  • 567
teabag
Problem sorter
281 Views
Message 5 of 5
Flag for a moderator
Helpful Answer

Re: SmartCall wrong setting


Ian_ wrote:

The SmartCall setting on my Galaxy S3 shows 'Talk Weekends' when my plan is 'Talk Unlimited'.  This stops me using SmartCall during weekdays.  Anyone know how to fix this.

Thanks.


Best advice would be to pop this question over into the landline phone section, usually gets seen quicker by staff.

It's a problem which has risen quite a lot lately, usally down to a wrong setting somewhere which staff can easily rectify for you. :-)

---------------------------------------------------------------
BB 200 - Hub 3, Phone Talk w/ends, Mobile Sim only £9 and £5 big bundle sim. Customer since 1993.
0 Kudos