Menu
Reply
  • 3
  • 0
  • 0
Br5968
Joining in
224 Views
Message 1 of 6
Flag for a moderator

Roaming fail

Called your people and bought data roaming package last night, arriver in Switzerland today and... No roaming.

Phone failing to connect to any Swiss (or even French - I'm in Geneva) network

Found wifi and your website's advice seems to be to call you, which I'd love to do, if only my phone was, er, roaming.

Pay monthly customer (for now) on a One Plus One.
0 Kudos
  • 4.43K
  • 139
  • 333
Moderator
Moderator
196 Views
Message 2 of 6
Flag for a moderator

Re: Roaming fail

Hi Br5968,

 

Welcome to the communitySmiley Happy

 

Sorry to hear roaming isn't working for you.

 

Can you give the following steps below a try please:

 

  • Turn your phone off and then back on again
  • Go into your phone settings and select a network manually.
  • Try removing your phone’s battery, while it’s still switched on – this helps reboot it and find a local network.

 

Something else you can check is roaming is active when you log into Your Account. Click on plans and devices then click the tab manage devices. Make sure roaming is set to on here. You can also check the call barring option to stop calls abroad isn't set to on.

 

Let me know how it goes.

 

Many thanks

 

Stephen_B
Community Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
  • 3
  • 0
  • 0
Br5968
Joining in
190 Views
Message 3 of 6
Flag for a moderator

Re: Roaming fail

I'd tried that before I posted here, though I can't log into my account because your recent upgrade has upset the password.

Eventually I bought Skype credit and spoke to one of your people who advised that although you'd happily taken my money for a data package, you hadn't actually turned roaming on...

24 hours later I am now roaming, but just for calls - still no mobile data service...
0 Kudos
  • 4.43K
  • 139
  • 333
Moderator
Moderator
187 Views
Message 4 of 6
Flag for a moderator

Re: Roaming fail

Hi Br5968.

 

Thanks for getting back to me.

 

Apologies for roaming not been activated on your account.

 

It sounds as though data roaming on your phone is not selected. Most handsets are set to off as default to protect the user from running up a bill while abroad.

 

If you look under settings generally in the section of your phone under networks you will see an option for data roaming.

 

If you could tell me the make of your phone I could be a bit more specific than I am aboveSmiley Happy 

 

Hope this helps.

 

Many thanks

Stephen_B
Community Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
  • 3
  • 0
  • 0
Br5968
Joining in
185 Views
Message 5 of 6
Flag for a moderator

Re: Roaming fail

As it says in my first post, my phone's a OnePlus One.

Data roaming was switched on from before I left the airport, so its not that.
0 Kudos
  • 4.43K
  • 139
  • 333
Moderator
Moderator
182 Views
Message 6 of 6
Flag for a moderator

Re: Roaming fail

Hi Br5968,

 

Apologies for missing that.

 

I'm sorry to say there's no other settings I can think of you could check if the data roaming setting has been turned on and you are still not able to use it.

 

If the problem persists I would recommend calling in on 789 or alternatively whilst abroad +447953967967 as my colleagues at Mobile will be able to check everything account wise is active for data roaming.

 

Many thanks

Stephen_B
Community Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos