Menu
Reply
  • 2
  • 0
  • 0
hilarya
Joining in
99 Views
Message 1 of 3
Flag for a moderator

Peru

Recently in Peru and was able to receive texts but not send them. Very annoying!!! Tried turning phone off/on and doing hard restart all to no avail. Also tried contacting Virgin on line but apart from ringing them ( at £2 a minute didn't really want to try it to see if it worked)  there's no other option apart from contacting the forums which it wouldn't let me do for some reason. Not  happy with Virgin at mo and will be cancelling once contract finished.

0 Kudos
Reply
  • 2.86K
  • 81
  • 125
Forum Team
Forum Team
78 Views
Message 2 of 3
Flag for a moderator

Re: Peru

Hi hilarya

Welcome to the community Smiley Happy

I'm sorry to hear about the recent issues you had whilst roaming.

In order to be able to both make and receive calls and texts while you're away, both the Roaming and 'International calls' option must be enabled on your account.

To check this is correctly set up, head over to your account and click on 'Plan and device' and then 'Manage services'. Just make sure the 'Going abroad' bit is set to 'on' and 'International call baring' is set to 'off'.

It's also important to ensure you send texts to the international version of the mobile number with '+44' replacing the '0' at the start (E.g. +447912345678) when you're text back to the UK from outside.

This should avoid you having any further issues when roaming, but let us know if we can offer further assistance.

Many thanks

Mark Y
Forum Team

Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos
Reply
  • 2
  • 0
  • 0
hilarya
Joining in
69 Views
Message 3 of 3
Flag for a moderator

Re: Peru

Hi Mark

Thanks for that but to be honest, it wasn't very helpful. I go abroad at least twice a year and have never had this problem before. I have double checked that roaming etc was was on/off (I did this before I went  as well) and I always input my numbers with +44. The only difference since I went to Egypt in February and it worked fine, is that I have a new phone. I now have a Samsung Galaxy A3 that also connects to the internet whenever it fancies. Could it be a problem with the phone?

Thanks

Hilary

0 Kudos
Reply