Menu
Reply
  • 2
  • 0
  • 0
delphzzzz
Joining in
93 Views
Message 1 of 3
Flag for a moderator

No service

I went abroad for a week and didn't use my mobile at all, except to search for wifi. I made no calls and used no mobile data. When I came back on sunday I had "no service". Then a couple of days later I had mobile service again so I thought all was back to normal.

 

This morning I am back to no service. There is definitely good coverage where I am now and at home.

 

Anyone else had this problem - and any idea what number I need to call to sort it? The website is no help as it just tells me coverage where I am is "excellent".

 

Hope this hasn't posted twice but didn't work a minute ago.

0 Kudos
  • 2
  • 0
  • 0
delphzzzz
Joining in
87 Views
Message 2 of 3
Flag for a moderator

Re: No service

Ah right, I found out what to do on another forum. Go into Settings and unselect automatic network detection, then let it detect all the networks and select Virgin. Apparently automatic doesn't always work. Phew, sorted.

0 Kudos
  • 4.44K
  • 139
  • 333
Moderator
Moderator
55 Views
Message 3 of 3
Flag for a moderator

Re: No service

Hi delphzzzz,

 

Thanks for your post.

 

Sorry to hear you had issues with no signal when coming back from abroad. 

 

I had a similar issue when I got  back from Spain a couple of weeks back. I had to manually select the network as well and then reboot the handset. 

 

Glad to hear you've managed to get it sorted.

 

If you need anything else just get back to us.

 

Take care

 

 

Stephen_B
Community Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos