Menu
Reply
  • 3
  • 0
  • 0
Pdm8253
Tuning in
175 Views
Message 1 of 9
Flag for a moderator

No data roaming in Canada with Rogers

I am in Canada, roaming on the Rogers network. I set data roaming to "On" in My Account before leaving, and the phone is all set up correctly. However I have not had any roaming data coverage at all, either in Montreal or Vancouver. No little "3G" icon at the top of the screen, no texts, no internet, no e-mails. Everything works fine on wi-if, naturally. Virgin Mobile make it impossible to contact them except by a chargeable call, of course. Have I missed something very obvious? Help please!

0 Kudos
Reply
  • 3.82K
  • 897
  • 1.7K
Superuser
Superuser
170 Views
Message 2 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

Hi Pdm8253,

 

your phone may have a switch for data roaming in the settings on the handset itself.

Possibly: Settings > More Networks > Mobile Networks > Data Roaming.

 

AlexKid :-)

 If you want to say thanks > click 'Kudos'.
Answered your question? > click 'Mark as Helpful Answer' also.

0 Kudos
Reply
  • 3
  • 0
  • 0
Pdm8253
Tuning in
158 Views
Message 3 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

Many thanks, but I have enabled this as well. Everything is set to "On", but nothing works.

0 Kudos
Reply
  • 3.82K
  • 897
  • 1.7K
Superuser
Superuser
154 Views
Message 4 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

Hi Pdm8253,

 

perhaps you could try Virgin's web chat for help: Help and Support - Contact Us > Mobile > Mobile not working > Chat online.

The advisors are often busy though so you may not get connected straight away.
(I would recommend keeping the page open just refresh it every few minutes).

 

AlexKid :-)

 If you want to say thanks > click 'Kudos'.
Answered your question? > click 'Mark as Helpful Answer' also.

0 Kudos
Reply
  • 3
  • 0
  • 0
Pdm8253
Tuning in
149 Views
Message 5 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

Thanks, but chat is not an available option - only "Call us", which will be an expensive option from here.

0 Kudos
Reply
  • 2.86K
  • 81
  • 125
Forum Team
Forum Team
124 Views
Message 6 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

Hi Pdm8253

Welcome to the community Smiley Happy

I'm sorry to hear about the issues you've had with the roaming service.

We'd just need to run some checks and make sure the 'data roaming' option is enabled on the account too.

I've dropped you a PM with some more information - please respond to the PM directly and we'll get you some help with this.
Many thanks

Mark Y
Forum Team

Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos
Reply
  • 6
  • 1
  • 1
mskitty
Tuning in
86 Views
Message 7 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

I'm having exactly the same problem. I believe everything is switched on on my phone. (always works on trips abroad in Europe), and it shows as connected to Rogers - but can't send texts or make calls.
Wondered if Mark managed to help pdm? If there was a solution?

Katherine
0 Kudos
Reply
  • 1.87K
  • 174
  • 338
J0hn
Super solver
79 Views
Message 8 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers

Try a manual network selection, bell worked for me a couple of months ago in Vancouver, Yellowknife and Edmonton
0 Kudos
Reply
  • 3.82K
  • 897
  • 1.7K
Superuser
Superuser
75 Views
Message 9 of 9
Flag for a moderator

Re: No data roaming in Canada with Rogers


mskitty wrote:
I'm having exactly the same problem. I believe everything is switched on on my phone. (always works on trips abroad in Europe), and it shows as connected to Rogers - but can't send texts or make calls.
Wondered if Mark managed to help pdm? If there was a solution?

Katherine

Hi Katherine,

 

I wonder, as your phone is connected to Virgin's partner network but you are unable to make calls. Might International call barring be active in your account.

Log into your Virgin Mobile account then click on  the "Plan and device" tab and go to "Manage my services".

Check that as well as "Roaming" being ON, "International call barring" is set to OFF.

 

AlexKid :-)

 If you want to say thanks > click 'Kudos'.
Answered your question? > click 'Mark as Helpful Answer' also.

0 Kudos
Reply