Menu
Reply
  • 2
  • 0
  • 0
Jenngalt
Joining in
878 Views
Message 1 of 7
Flag for a moderator

'No Service' and no 'carrier' tab in settings??

Hi, I'm at my wits end with my iPhone 5c that Virgin provide. Starting this month, I have constant 'No Signal' or 'Searching' for signal. I've tried everything, I've updated my phone, I've spent countless hours on the phone to the unhelpful virgin staff and have gotten nowhere.

The service will work for about 30 seconds if I reset my phone, which is obviously very impractical. Also, there is no way to acces 'Carrier' settings on my phone as I don't have that option? I reset my phone again today, the option appeared, only to disappear again?

I have no idea what's going on and have had 0 help from any of the Virgin staff.
Tags (4)
0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
850 Views
Message 2 of 7
Flag for a moderator

Re: 'No Service' and no 'carrier' tab in settings??

Hi Jenngalt,

 

Welcome to the forums Smiley Happy I want to get these signal issues all sorted for you. 

 

Can you let me know if this happens in more than one area?

 

Let me know as soon as you can.


Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
838 Views
Message 3 of 7
Flag for a moderator

Re: 'No Service' and no 'carrier' tab in settings??

Hi Jenngalt,

 

How's this looking for you currently?


Let me know as soon as you can.

Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 2
  • 0
  • 0
Jenngalt
Joining in
830 Views
Message 4 of 7
Flag for a moderator

Re: 'No Service' and no 'carrier' tab in settings??

Yes, all areas. I've had a new sim, I've wiped my phone, I've reset m network settings, I've been on the phone for over 10 hours to Virgin.

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
824 Views
Message 5 of 7
Flag for a moderator

Re: 'No Service' and no 'carrier' tab in settings??

Thanks for coming back to me Jenngalt Smiley Happy


To me, this seems like there could be a fault with the phone. Are you able to try your sim in another phone by any chance?

 

Let me know as soon as you can.

 

Thanks,


Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 5
  • 0
  • 0
Coralie
Tuning in
797 Views
Message 6 of 7
Flag for a moderator

Re: 'No Service' and no 'carrier' tab in settings??

Hello,

I post here as I have the same problem.
I have an Iphone 5c I bought new more than a year ago in France. I moved in UK, had a virgin pay as you go, then switched to Monthly... no problem. Good network, happy with the offer... all good Smiley Happy
Because I just moved abroad, I called Virgin a month ago to ask if possible to switch back on Pay as You Go so I keep the same nr - no problem.

I left for Senegal on the 6th. By then, I was still Pay Monthly: coverage OK, no problem. I am in Dakar and we have excellent network.
hen on the 12th, it switched to Pay as You Go and from that point, it indicated "no service".
My Iphone asked me to update carrier settings... so I tapped OK. But nothing, still "no service". My Roaming is OK, though... Called the customer service twice.

When I turn off my phone and back again, it indicates Orange Senegal network for a couple of seconds, eventually indicate 1 bar network, then back to "No Service". I can't even try to connect to another network (Sentel is in agreement with Virgin), because it can't find anything.

I am wondering if it's not a question of carrier settings, but I don't know how to do ?

Can you help, please? I will be abroad for a really long time, I would be really unhappy if I can't get my connection back ! Smiley Happy
Thanks !
Coralie

I even topped up GBP5 in case that was the problem, but still nothing, and Customer service can't find any answer neither.

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
765 Views
Message 7 of 7
Flag for a moderator

Re: 'No Service' and no 'carrier' tab in settings??

Hi Coralie,

 

Welcome to the forums Smiley Happy

 

That's a good question! What is more than likely to have happened is when you switched back to Pay as You Go, the roaming may have reset on the phone. So I can look into this, I've sent you a PM detailing the next steps. You can view this by clicking the purple envelope in the top right.

 

Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know