Menu
Reply
  • 4
  • 0
  • 0
joerice50
Joining in
240 Views
Message 1 of 5
Flag for a moderator

No Service Abroad

No service abroad despite depositing £50 and being a virgin media customer for years! Can someone tell Virgin to sort this as I cannot make or receve calls. Where is Virgin's Customer focus ?
0 Kudos
Reply

Helpful Answers
  • 3.82K
  • 896
  • 1.7K
Superuser
Superuser
410 Views
Message 4 of 5
Flag for a moderator
Helpful Answer

Re: No Service Abroad


Enceladus1 wrote:

Try logging into your online "Mobile Your Account" using a device that has working internet access. Click on the "Plan and device" tab. Check that "Roaming" is switched ON and "International call barring" is switched ON. Correct if necessary and then switch the phone off and on. It might take 24 hours for the change to propagate to wherever you are, so periodically re-start the phone if needs be.


"International call barring" needs to be set to OFF

AlexKid :-)

 If you want to say thanks > click 'Kudos'.
Answered your question? > click 'Mark as Helpful Answer' also.


All Replies
  • 134
  • 16
  • 31
Enceladus1
Superfast
223 Views
Message 2 of 5
Flag for a moderator

Re: No Service Abroad

Try logging into your online "Mobile Your Account" using a device that has working internet access. Click on the "Plan and device" tab. Check that "Roaming" is switched ON and "International call barring" is switched ON. Correct if necessary and then switch the phone off and on. It might take 24 hours for the change to propagate to wherever you are, so periodically re-start the phone if needs be.

0 Kudos
Reply
  • 4
  • 0
  • 0
joerice50
Joining in
211 Views
Message 3 of 5
Flag for a moderator

Re: No Service Abroad

Hi

And thanks for the adbice I have folloed your instructions lets see if Virgin turn on international calls shortly.

Thanks

Joe
0 Kudos
Reply
  • 3.82K
  • 896
  • 1.7K
Superuser
Superuser
411 Views
Message 4 of 5
Flag for a moderator
Helpful Answer

Re: No Service Abroad


Enceladus1 wrote:

Try logging into your online "Mobile Your Account" using a device that has working internet access. Click on the "Plan and device" tab. Check that "Roaming" is switched ON and "International call barring" is switched ON. Correct if necessary and then switch the phone off and on. It might take 24 hours for the change to propagate to wherever you are, so periodically re-start the phone if needs be.


"International call barring" needs to be set to OFF

AlexKid :-)

 If you want to say thanks > click 'Kudos'.
Answered your question? > click 'Mark as Helpful Answer' also.

  • 134
  • 16
  • 31
Enceladus1
Superfast
169 Views
Message 5 of 5
Flag for a moderator

Re: No Service Abroad

Whoops. Thanks for spotting that, a typo on my part. International call barring needs to be set to OFF and Roaming set to ON

0 Kudos
Reply