Menu
Reply
  • 21
  • 1
  • 0
roadrunner46
On our wavelength
218 Views
Message 1 of 4
Flag for a moderator

New 4G sim wont work

Yesterday I got a replacement 4G sim for my Samsung S7Edge. Got it in and had the correct settings LTE/3G/2G and checked with VM online help but could not get the mobile data. The guy told me there was a problem with EE in that when he went to "Turn on" my data to 4g it would not hold. He told me to keep ytrying and would ring back in the afternoon. He kept his word but could not fix the fault and I now have to wait to Monday until he can take the matter forward as a fault. However, I had to tell him that I have now established that since fitting the new sim I could not get anything other than Wifi on my phone. He said that may be due to a deffective mast near me and to keep trying. This morning still getting the message "Unable to connect - try again later.....

In desperation I removed the "Shiny new 4G sim" and re-inserted the "Old" original 2g/3g one and lo and behold I got all the phone serivces immediately plus a backlog of texts from friends and family..

Does this mean I have a faulty sim? should I keep the old one in the phone I am completely confused and FED UP with VM

 

0 Kudos
Reply
  • 116
  • 24
  • 41
Magic_M
Up to speed
209 Views
Message 2 of 4
Flag for a moderator

Re: New 4G sim wont work

Have you activated the new SIM? There should have been instructions on how to do this included.

If you've already done that then I think you'll need to call 789 again.

 

-

http://community.virginmedia.com/t5/Virgin-Mobile/4G-Sim-Activation/m-p/3255668#M72177

http://help.virginmedia.com/system/selfservice.controller?CONFIGURATION=1003&PARTITION_ID=1&secureFl...

0 Kudos
Reply
  • 21
  • 1
  • 0
roadrunner46
On our wavelength
203 Views
Message 3 of 4
Flag for a moderator

Re: New 4G sim wont work

Hi there,

The new sim came with a card that said Get your iPhone ready for 4G. Not a bad start as VM know I am using a Samsung S7Edge as I told them when I ordered the upgrade to 4G. Anyway undaunted I followed the 3 steps and it showed LTE/3G/2G as my connection, however, it didnt get it going. So I then spent 25 minutes talking to 789 and was told he could not get their system to allow him to change it but said was getting an error message on his system (not on my sim). He rangme back at 4pm as planned and said he still could not get mobile data to update but again thopught it was his end. He then said that He could only request 1 ticket for fault in 24 hours so I have now to wait until Monday morning before he will contact me again. In the meantime I was left with no usable phione. I have swapped back to the old sim and everything is working (even showing mobile data useage). It still shows connection as LTE/3G/2G but is at least working.  I will swap the sims back when he phones and see where we go from then (if he does phone). My plan has been changed in my online account to the new tarif/f4g since 17th November. So So frustrating

0 Kudos
Reply
  • 21
  • 1
  • 0
roadrunner46
On our wavelength
198 Views
Message 4 of 4
Flag for a moderator

Re: New 4G sim wont work

Further to this, After the advice I received this morning I reinserted the new sim and went into my account I used the activate the sim and it said it had been activated @ 20/11/16 I restarted my phone and Hey Presto it showed Virgin and is working properly now. I then got a text saying that my old sim was now inactive. Why Oh Why did it take so long even when I spent 2 X  20+ minute sessions on line with VM help, only to be helped on the forum within minutes. Thanks Guys

0 Kudos
Reply