Menu
Reply
  • 8
  • 0
  • 1
khismet
Tuning in
435 Views
Message 1 of 22
Flag for a moderator

Never getting 3G connection

When I first got this phone/sim combination (Galaxy S4), I would regularly get a 3G signal - now I never, ever get 3G and this has been going on for months. I get "E" and "H+" but that's it. Network speed according to Speedtest is a massive 0.07 Mbs Smiley Sad

 

Network mode is set to LTE/WCDMA/GSM (auto connect)

 

Any ideas?

  • 3
  • 0
  • 0
VictoriaPlum
Joining in
424 Views
Message 2 of 22
Flag for a moderator

Re: Never getting 3G connection

Same problem here. I really wish I hadn't renewed my contract

0 Kudos
Reply
  • 62
  • 3
  • 7
ericos
Dialled in
413 Views
Message 3 of 22
Flag for a moderator

Re: Never getting 3G connection

0 Kudos
Reply
  • 8
  • 0
  • 1
khismet
Tuning in
405 Views
Message 4 of 22
Flag for a moderator

Re: Never getting 3G connection

That's moderately encouraging, and does explain why I no longer see the 3G symbol, but:

Depending on the different networks and devices, accessible HSPA+ speeds can either be 14.4Mbps and 21Mbps, with 42Mbps only possible on some networks.

 I'm getting 0.07Mb, or approximately 0.4% of the 14.4Mbs lower tier speed

0 Kudos
Reply
  • 8
  • 0
  • 1
khismet
Tuning in
404 Views
Message 5 of 22
Flag for a moderator

Re: Never getting 3G connection

In passing, whoever sent me a private message about this, it hasn't arrived; please try again (I got the email alert, but there's not actually a message)

0 Kudos
Reply
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
386 Views
Message 6 of 22
Flag for a moderator

Re: Never getting 3G connection

Hi Khismet,

 

Thanks for your posts Smiley Happy

 

I'm really sorry that you've been getting slow speeds. I want to get this fixed for you. Are you able to let me know if this happens in more than one area?


Come back to me when you can.


Thanks,
 

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 8
  • 0
  • 1
khismet
Tuning in
378 Views
Message 7 of 22
Flag for a moderator

Re: Never getting 3G connection

Hi Mat,

 

Yes, everywhere. Some zones are worse than others, I can occasionally get up to about 1.1 Mb, but most of the time it's down around 0.05 to 0.5

 

0 Kudos
Reply
  • 2.26K
  • 30
  • 199
jhuk
Knows their stuff
362 Views
Message 8 of 22
Flag for a moderator

Re: Never getting 3G connection

Going by the old phone that shows VM using Orange or T-Mobile network (basic old 2G phone),  I assume they are both same speed just different terms used by different carriers.

 

Or both terms could be used by both carries and I have not noticed yet, think it defaults to T-Mobile as primary though and I am sure I have even seen 02 on screen.

 

I never see Virgin on screen or in Manual Network Selection menu in the phones settings.

 

I cannot tell on new phone as its says Virgin in Network as it should do and 3G+ or H+.

 

Still new to all this so learning.

0 Kudos
Reply
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
332 Views
Message 9 of 22
Flag for a moderator

Re: Never getting 3G connection

Hi khismet,

 

Thanks for coming back to me Smiley Happy So we can look into this for you, are you able to pop your sim in another phone to see if the problem continues?

 

Let me know how you get on with this.


Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 119
  • 6
  • 34
KevAmiga
Up to speed
325 Views
Message 10 of 22
Flag for a moderator

Re: Never getting 3G connection

Could this be an API problem? Maybe configuration?


TiVo, 150mb BB, Telco, Mobile.. .got em all Smiley Happy

0 Kudos
Reply