Menu
Reply
  • 1
  • 0
  • 0
jayjay2019
Just joined
96 Views
Message 1 of 3
Flag for a moderator

NETWORK.

Hi, I have just received a new sim card and i have all ready activated on my account online, but it will not register to a newtwork. On my phone im given to option on 3g virgin, 2g virgin with little house symbols next to them then one that says 2g virgin it doesnt connect but then will connect to the 2g one (with out a symbol) for about 5 minutes i cant send a text or make a call then it goes off again, Is there any help I can get please I have a contract with you and its annoying me as im still paying for it but can not use it.

 

Thanks.

 

James McLean.

0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
70 Views
Message 2 of 3
Flag for a moderator

Re: NETWORK.

Hi James,


Welcome to the forums Smiley Happy
 

Sorry to hear you're having some issues with the sim card on the phone. It can take up to 24 hours for the sim to activate properly on the network. If it's still having issues after 24 hours, let me know and I'll make sure I fix it for you.

 

Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos
  • 8.26K
  • 236
  • 340
Forum Team (Retired) Mat_H
Forum Team (Retired)
58 Views
Message 3 of 3
Flag for a moderator

Re: NETWORK.

Hi James,

 

How's this looking for you currently?

 

Let me know if you need anything at all.

 

Thanks,

Mat


Who's who? Find out more about our community members. Good folk to know


0 Kudos